Tab shortcuts ⌥+number conflict with entering accented characters, although there is ⌘+Number as well.

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: nofrasop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

There is shortcut Ctrl+Number in Windows and ⌘+Number on Mac to quickly switch to a tab.

Unfortunately, someone decided to duplicate this feature on Mac using ⌥+Number.

There's a plenty of non-US keyboard layouts, that use ⌥+Number to produce some symbol (accented character, punctuation etc...). It works everywhere but Firefox.

Because of this, ⌥+Number shortcuts should be disabled. We have ⌘+Number anyway.

Reproducible: Always

Steps to Reproduce:
1. Install some non-US layout 
2. Type ⌥+2,⌥+3,… to type some accented symbols
3. ?????
4. PROFIT!!!
Actual Results:  
Tab switch.

Expected Results:  
Entered the character.

Comment 1

9 years ago
Do you have any extensions installed? AFIK by default, Firefox doesn't make use of Opt+number to switch tabs.
(Reporter)

Comment 2

9 years ago
You have right, that was Speed Dial extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.