Case where crash happens involving save to draft warning...

VERIFIED FIXED

Status

P2
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: kinmoz)

Tracking

({crash})

Trunk
x86
All
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++])

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Using sept15 commercial build
linux rh6.0 and NT 4.0


I crash consistently when closing open message compose window, selecting any
option in save to draft warning dialog following these steps:

1.  From mail window, New Msg.
2.  Type an addressee, subject and body text having spelling errror(s).
3.  Click Spell Check button.  Spell check dialog opens identifying spelling
error... Click the spell check dialog's Xclose box.  Spell check dialog closes.
4.  Click the Xclose box in compose window. Save to draft warning appears.
5.  Click any of the buttons Cancel/Save/Don't Save in the draft warning dialog.

Result:  crash occurs.

Talkback stack(s) coming...
(Reporter)

Updated

18 years ago
QA Contact: esther → pmock
(Reporter)

Updated

18 years ago
Keywords: crash
(Reporter)

Comment 1

18 years ago
Created attachment 14821 [details]
talkback 17500369
(Reporter)

Comment 2

18 years ago
Created attachment 14822 [details]
talkback 17432830
(Reporter)

Comment 3

18 years ago
*** Bug 55050 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
nominating for rtm.  This crash seems like it will be pretty easy to reproduce
for people using the spell checker.
Keywords: rtm

Comment 5

18 years ago
It seems that if you spell check this is a situation you might encounter a lot. 
 The stack doesn't look like mailnews code.  JF, if you don't think you are 
causing this, could you reassign.
Priority: P3 → P2
Whiteboard: [rtm need info]

Comment 6

18 years ago
Is this really linux only?

Comment 7

18 years ago
changed to all. Laurel's original comments say NT as well.
OS: Linux → All

Comment 8

18 years ago
JF, can you comment to Scott's question?  If you're the wrong owner we need to
know immediately!
I can reproduce this crash with an optimized build but for some reason, I cannot initialize the spell checker with a 
commercial debug build (Mac or Window). Initialization failed in nsEditorShell::InitSpellChecker() when calling 
mSpellChecker->SetDocument(tsDoc, PR_FALSE) with an error 0xC1F30001. Kin any idea?

Anyway, at this point, I cannot tell if I am the right owner for this bug. Still investigating...
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Comment 10

18 years ago
I have a fix for this problem.
Assignee: ducarroz → kin
Status: ASSIGNED → NEW
(Assignee)

Comment 11

18 years ago
Accepting bug. changing milestone to M19.
Status: NEW → ASSIGNED
Target Milestone: M18 → M19
(Assignee)

Comment 12

18 years ago
Created attachment 16669 [details] [diff] [review]
Patch that fixes the crash.
(Assignee)

Comment 13

18 years ago
Cc brade@netscape.com.

Can I get brade to review and sfraser to super review this fix please? Thanks!

Comment 14

18 years ago
r=brade

Comment 15

18 years ago
sr=sfraser
(Assignee)

Comment 16

18 years ago
Removing "need info" from the whiteboard, and sending request to PDT for rtm++ 
approval.
Whiteboard: [rtm need info] → [rtm]

Comment 17

18 years ago
rtm++
Whiteboard: [rtm] → [rtm++]

Comment 18

18 years ago
kin has a fix for this and a patch.

anthonyd
Whiteboard: [rtm++] → [rtm++],FIX IN HAND, PATCH
(Assignee)

Comment 19

18 years ago
Fix checked into the Netscape_20000922_BRANCH:

    mozilla/editor/ui/dialogs/content/EdSpellCheck.js   revision 1.24.6.1
    mozilla/editor/ui/dialogs/content/EdSpellCheck.xul  revision 1.34.6.1

and the trunk:

    mozilla/editor/ui/dialogs/content/EdSpellCheck.js   revision 1.25
    mozilla/editor/ui/dialogs/content/EdSpellCheck.xul  revision 1.35


Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [rtm++],FIX IN HAND, PATCH → [rtm++]

Comment 20

18 years ago
Using today commercial branch build, the crash has not been reproducible on 
win32, linux, and mac using the following build:
 win32 commercial seamonkey build 2000-101109-mn6 installed on P500 Win98
 linux commercial seamonkey build 2000-101109-mn6 installed on P200 RedHat 6.2
 macos commercial seamonkey build 2000-101110-mn6 installed on G3/400 OS 9.04

... but will wait for bug 56129 to be fixed first since saving draft is broken.

Comment 21

18 years ago
Linux (2000-10-18-09 MN6)
Win32 (2000-10-18-10 MN6)
Mac (2000-10-18-08 MN6)
Following the same scenario, I try save/don't save/cancel and  Xclose box, no
crash occurs.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.