Closed Bug 528699 Opened 11 years ago Closed 11 years ago

browser_522545.js frequent failure with Win debug builds, infrequent elsewhere

Categories

(Firefox :: Session Restore, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 3.7a1
Tracking Status
status1.9.2 --- beta4-fixed

People

(Reporter: dao, Assigned: dao)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

WINNT 5.2 mozilla-central test everythingelse

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258196163.1258199396.27854.gz

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
Whiteboard: [orange]
seeing this on Linux too
OS: Windows XP → All
Hardware: x86 → All
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258206413.1258213530.3300.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/14 05:46:53
"s: moz2-win32-slave18"
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258212890.1258218471.25395.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/14 07:34:50
"s: moz2-win32-slave41"
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258227286.1258234235.11709.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/14 11:34:46
"s: moz2-win32-slave22"
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258224139.1258231261.11426.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/14 10:42:19
"s: moz2-win32-slave10"
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258241716.1258248475.2901.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/14 15:35:16  
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:mozilla
I think this isn't intermittent; it actually looks permanent.
And then we had one cycle when it didn't happen.  Just one so far today, though.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258258769.1258264312.12608.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/14 20:19:29
"s: moz2-win32-slave37"
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258264698.1258271417.25031.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/14 21:58:18
"s: moz2-win32-slave02"
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258295298.1258302436.6167.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/15 06:28:18
"s: moz2-win32-slave18"
I think the first time this happened was:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258186193.1258193165.23978.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/14 00:09:53  
"s: moz2-win32-slave25"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
Summary: browser_522545.js intermittent failure → browser_522545.js permanent failure with Win debug builds (intermittent on Linux?)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258302997.1258308188.8545.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/15 08:36:37
"s: moz2-win32-slave16"
Actually, this isn't quite permanent. The latest WINNT 5.2 mozilla-central debug test everythingelse is completely green...
Summary: browser_522545.js permanent failure with Win debug builds (intermittent on Linux?) → browser_522545.js frequent failure with Win debug builds (intermittent on Linux?)
i have been able to reproduce in my slow VM, with an optimized build.

Running chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js...

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | Only one browser window should be open initially

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | No history entries still sets currentURI to about:blank - Got http://localhost:8888/browser/browser/components/sessionstore/test/browser/browser_461743_sample.html, expected about:blank

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was correctly restored

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear restored as expected

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored - Got http://localhost:8888/browser/browser/components/sessionstore/test/browser/browser_461743_sample.html, expected example.com

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly updated

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | No history entries still sets currentURI to about:blank

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was correctly restored

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear restored as expected

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly updated

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was correctly restored

TEST-PASS | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear restored as expected

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/../browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258386533.1258388406.30905.gz
WINNT 5.2 mozilla-central opt test everythingelse

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Only one browser window should be open initially - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear is 0 to start - Got 2, expected 0
(In reply to comment #27)
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258384767.1258388015.27405.gz
> WINNT 5.2 mozilla-central opt test everythingelse

This is bug 528776.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258381886.1258388789.2489.gz
WINNT 5.2 mozilla-central debug test everythingelse

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear=2 caused userTypedValue to be loaded - Got http://example.com/0, expected http://example.com/
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was null after loading a URI - Got http://example.com, expected null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear reset to 0 - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value set after loading URI - Got mozilla.org, expected http://example.com/
Taking since I wrote this test. I think adding a couple load listeners will help.
Assignee: nobody → paul
i can reproduce constantly locally, if you need testing.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258392614.1258401217.20338.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/16 09:30:14

TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | No history entries still sets currentURI to about:blank
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was correctly restored
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear restored as expected
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly updated
++DOMWINDOW == 104 (06FF7E08) [serial = 1860] [outer = 081D45A0]
++DOMWINDOW == 105 (0723CAB0) [serial = 1861] [outer = 071F8D38]
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | No history entries still sets currentURI to about:blank
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was correctly restored
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear restored as expected
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly updated
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 2755
NEXT ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was correctly restored
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear restored as expected
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
++DOMWINDOW == 106 (07B41BD0) [serial = 1862] [outer = 081D45A0]
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was correctly restored
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear restored as expected
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue
pldhash: for the table at address 07BCEA40, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07BCE9D8 == 9
++DOMWINDOW == 107 (06C51320) [serial = 1863] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 108 (0872BAA0) [serial = 1864] [outer = 06C512F0]
pldhash: for the table at address 0844DA50, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0844D9E8 == 10
++DOMWINDOW == 109 (0747BA10) [serial = 1865] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 110 (082437B0) [serial = 1866] [outer = 0747B9E0]
pldhash: for the table at address 080BDDD8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 080BDD70 == 11
++DOMWINDOW == 111 (07CA6B18) [serial = 1867] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 112 (07B41210) [serial = 1868] [outer = 07CA6AE8]
pldhash: for the table at address 05F1AA20, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 05F1A9B8 == 12
++DOMWINDOW == 113 (07A99E78) [serial = 1869] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 114 (07263058) [serial = 1870] [outer = 07A99E48]
pldhash: for the table at address 08013DD0, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 08013D68 == 13
++DOMWINDOW == 115 (06CC2658) [serial = 1871] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 116 (05E95AB8) [serial = 1872] [outer = 06CC2628]
pldhash: for the table at address 08430CA8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 08430C40 == 14
++DOMWINDOW == 117 (08325520) [serial = 1873] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 118 (057F7C88) [serial = 1874] [outer = 083254F0]
pldhash: for the table at address 07B3FAB8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07B3FA50 == 15
++DOMWINDOW == 119 (05986D38) [serial = 1875] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 120 (05BF32B8) [serial = 1876] [outer = 05986D08]
pldhash: for the table at address 07B91568, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07B91500 == 16
++DOMWINDOW == 121 (0716A2C0) [serial = 1877] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 122 (07453560) [serial = 1878] [outer = 0716A290]
pldhash: for the table at address 07A3C390, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07A3C328 == 17
++DOMWINDOW == 123 (07EF12D8) [serial = 1879] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 124 (05E97E28) [serial = 1880] [outer = 07EF12A8]
pldhash: for the table at address 07ECCCB8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07ECCC50 == 18
++DOMWINDOW == 125 (084D8C00) [serial = 1881] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 126 (05E02C30) [serial = 1882] [outer = 084D8BD0]
pldhash: for the table at address 0798CD20, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0798CCB8 == 19
++DOMWINDOW == 127 (07F96858) [serial = 1883] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 128 (0157DEE8) [serial = 1884] [outer = 07F96828]
pldhash: for the table at address 081D2BB0, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 081D2B48 == 20
++DOMWINDOW == 129 (07D5AC60) [serial = 1885] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 130 (06939C38) [serial = 1886] [outer = 07D5AC30]
pldhash: for the table at address 07A26B90, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07A26B28 == 21
++DOMWINDOW == 131 (07FE7D20) [serial = 1887] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 132 (08095348) [serial = 1888] [outer = 07FE7CF0]
pldhash: for the table at address 08094D90, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 08094D28 == 22
++DOMWINDOW == 133 (081D1068) [serial = 1889] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 134 (07BD5200) [serial = 1890] [outer = 081D1038]
pldhash: for the table at address 07B3D2F0, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07B3D288 == 23
++DOMWINDOW == 135 (082C4BE8) [serial = 1891] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 136 (03E5EB90) [serial = 1892] [outer = 082C4BB8]
pldhash: for the table at address 08493B70, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 08493B08 == 24
++DOMWINDOW == 137 (07CA42E8) [serial = 1893] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 138 (05F2FE40) [serial = 1894] [outer = 07CA42B8]
pldhash: for the table at address 07BF3C48, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07BF3BE0 == 25
++DOMWINDOW == 139 (07104148) [serial = 1895] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 140 (05B58980) [serial = 1896] [outer = 07104118]
pldhash: for the table at address 06FCAC60, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 06FCABF8 == 26
++DOMWINDOW == 141 (06980DC0) [serial = 1897] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 142 (03BE6AD8) [serial = 1898] [outer = 06980D90]
pldhash: for the table at address 07426F88, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07426F20 == 27
++DOMWINDOW == 143 (074905C8) [serial = 1899] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 144 (0685C698) [serial = 1900] [outer = 07490598]
pldhash: for the table at address 070743B0, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07074348 == 28
++DOMWINDOW == 145 (0717F130) [serial = 1901] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 146 (069E1990) [serial = 1902] [outer = 0717F100]
pldhash: for the table at address 06FC7B50, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 06FC7AE8 == 29
++DOMWINDOW == 147 (071376D8) [serial = 1903] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 148 (05F57190) [serial = 1904] [outer = 071376A8]
pldhash: for the table at address 08365D28, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 08365CC0 == 30
++DOMWINDOW == 149 (082C6860) [serial = 1905] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 150 (07994DF0) [serial = 1906] [outer = 082C6830]
pldhash: for the table at address 07CBC350, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 07CBC2E8 == 31
++DOMWINDOW == 151 (0794D380) [serial = 1907] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 152 (07A1F220) [serial = 1908] [outer = 0794D350]
pldhash: for the table at address 06841730, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 068416C8 == 32
++DOMWINDOW == 153 (07CF7D60) [serial = 1909] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 154 (05CEB6C8) [serial = 1910] [outer = 07CF7D30]
pldhash: for the table at address 071F43B8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 071F4350 == 33
++DOMWINDOW == 155 (05CF12D0) [serial = 1911] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 156 (07A82F70) [serial = 1912] [outer = 05CF12A0]
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/netwerk/base/src/nsSimpleURI.cpp, line 224
++DOMWINDOW == 157 (07C37798) [serial = 1913] [outer = 06C512F0]
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | At least one tab has it's entry in SH
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | At least one tab has a userTypedValue with userTypedClear with no loaded URL
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue is empty to start
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear is 0 to start
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was set when changing gURLBar.value
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear was not changed when changing gURLBar.value
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | sessionstore got correct userTypedValue
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | sessionstore got correct userTypedClear
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear=2 caused userTypedValue to be loaded - Got http://example.com/0, expected http://example.com/
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was null after loading a URI - Got http://example.com, expected null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear reset to 0 - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value set after loading URI - Got mozilla.org, expected http://example.com/
++DOMWINDOW == 158 (070E8468) [serial = 1914] [outer = 06C512F0]
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Only one browser window should be open eventually
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258414881.1258419648.1087.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/16 15:41:21
"s: moz2-win32-slave37"
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258447177.1258452173.7211.gz

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear=2 caused userTypedValue to be loaded - Got http://example.com/0, expected http://example.com/
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was null after loading a URI - Got http://example.com, expected null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear reset to 0 - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value set after loading URI - Got mozilla.org, expected http://example.com/
(In reply to comment #43)
> If this was caused by code changes, it was probably caused by one of these:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3b865fb41da3&tochange=b89fd003bdd9

I don't think it is. The tests aren't great.

---

So I'm trying to put the browser in a blank state before running the next test & that often works, but...

I think I'm seeing that using setBrowserState with a blank (tabs: [{entries:[]}]) state is not clearing userTypedValue, and I think is causing some issues (at least sometimes). Is that something we should fix in sessionstore? Or should userTypedValue = null be a precondition in the edge case (just tests?) that call setBrowserState with this blank state?

That's a bit tangential to this bug, and if it's something we should fix, should block the original bug 522545.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258462064.1258469113.8433.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/17 04:47:44  
"s: moz2-win32-slave28"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258460610.1258464893.23557.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/17 04:23:30
"s: moz2-win32-slave32"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear is 0 to start - Got 2, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear=2 caused userTypedValue to be loaded - Got http://example.com/0, expected http://example.com/
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedValue was null after loading a URI - Got http://example.com, expected null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypeClear reset to 0 - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value set after loading URI - Got mozilla.org, expected http://example.com/
http://hg.mozilla.org/mozilla-central/rev/882b724fcc37

Backed out one of my changes to see if it's the cause of the orange, since it's easier to do than hypothesize.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258526166.1258528692.5674.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/17 22:36:06
s: moz2-darwin9-slave06
Built from 52d5ed462c9e
"Address bar's value correctly restored - Got , expected example.com"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored - Got , expected example.com

OS X 10.5.2 mozilla-central opt test everythingelse
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258619548.1258622168.6896.gz
Summary: browser_522545.js frequent failure with Win debug builds (intermittent on Linux?) → browser_522545.js frequent failure with Win debug builds, infrequent elsewhere
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:config, expected about:mozilla
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.com, expected example.org

WINNT 5.2 mozilla-central debug test everythingelse
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258616760.1258626333.22381.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258647481.1258649876.6073.gz
WINNT 5.2 mozilla-central opt test everythingelse on 2009/11/19 08:18:01
"s: moz2-win32-slave33"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | userTypedClear is 0 to start - Got 2, expected 0
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258656981.1258662146.21384.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/19 10:56:21
s: moz2-darwin9-slave09
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored - Got , expected example.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258667795.1258671292.28801.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/19 13:56:35
"s: moz2-win32-slave17"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:config, expected about:mozilla
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.com, expected example.org
FYI I have a patch locally that should have far fewer problems, though it still fails occasionally. I'm still working around an issue I'm having with it before I put it up.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258685316.1258688146.25873.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/19 18:48:36
s: moz2-darwin9-slave06
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored - Got , expected example.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258682664.1258685217.25584.gz#err1
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/19 18:04:24
s: moz2-darwin9-slave10
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored - Got , expected example.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258683139.1258691198.27075.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/19 18:12:19
"s: moz2-win32-slave20"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258688303.1258691672.31973.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/19 19:38:23  
s: moz2-darwin9-slave02
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored - Got , expected example.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258688039.1258694999.3465.gz
WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/19 19:33:59
"s: moz2-win32-slave32"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | browser.currentURI set to current entry in SH - Got about:blank, expected about:config
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_522545.js | Address bar's value correctly restored to userTypedValue - Got example.org, expected example.com
Attached patch patchSplinter Review
Attachment #413566 - Flags: review?(paul)
Comment on attachment 413566 [details] [diff] [review]
patch

This seems to be working as (or better) than what I was doing. I had some other changes I wanted to make to this test, but I can followup with that if this doesn't get rid of the orange
Attachment #413566 - Flags: review?(paul) → review+
http://hg.mozilla.org/mozilla-central/rev/669274cc36cf

(In reply to comment #67)
> This seems to be working as (or better) than what I was doing.

Did you have a similar approach? Since you mentioned remaining problems in your previous comment and my fix was very reliable for me locally, I figured you were on the wrong track.
(In reply to comment #69)
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258743089.1258749852.25411.gz&fulltext=1
> 
> WINNT 5.2 mozilla-central debug test everythingelse on 2009/11/20 10:51:29

that's before the push
Attached patch my WIPSplinter Review
(In reply to comment #68)
> Did you have a similar approach? Since you mentioned remaining problems in your
> previous comment and my fix was very reliable for me locally, I figured you
> were on the wrong track.

You can see what I was doing here (a bunch of crap in there)...

In summary, I was setting up a blank state before running each test, redid lots of tabs test so it's testing more specifically. The just used load events instead of using a progress listener. tab.busy is cleared in onLocationChange, so I looked at that... The part I'd like to get in is the changes to lots of tabs test.

The problem I was having at the end was because of doing JSON.stringify & JSON.parse (which broke because of state from a previous test). Not too hard to fix, just took some tracking down.

I think long term, if we get head.js support for browser-chrome, it would be good to take all of what we've learned in this and other sessionstore tests: reset to a blank state before actually running the test, getting better at waiting for state, etc.
I'm not so sure about the waiting approach. I'd rather have the component not fail in stress situations.
Can this be marked as fixed (and status1.9.2:beta4-fixed?) now?
(In reply to comment #75)
> Can this be marked as fixed (and status1.9.2:beta4-fixed?) now?

Since it looks like there haven't been any reports of it in the past week+, let's do that.
Assignee: paul → dao
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Target Milestone: --- → Firefox 3.7a1
Still no failures...verified.
Status: RESOLVED → VERIFIED
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/suite/common/tests/browser/browser_522545.js | sessionstore got correct userTypedValue - Got example.org, expected mozilla.org

On SM Linux Md

Noting it here incase my work proves it is this bug (or if anyone else sees this bug again)
Err == not this bug, that failure is in a suite/ test.
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.