Always load remote Content behavior should also search System Address Book

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
RESOLVED INVALID
9 years ago
4 years ago

People

(Reporter: Peter Steinauer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

When Determining whether or not to display remote content Thunderbird should look in the system address book as well as the application's address books. With the current behavior when you select an email from someone who is in your system address book it doesn't display the images until you click the 'always load…' link. When you then click that link to add the user it gives you the option to add it to the personal address book or the collected addresses. Adding to either will create a duplicate contact which isn't desirable.  Since the Mac OS X address book is used for so many other things its fairly important to some users that that be where most contacts are kept..

Reproducible: Always

Steps to Reproduce:
1. Select an email with images imbedded from a contact that is in your Mac OS X Addressbook but NOT in thunderbird's contact list.
2. Click on 'Always load remote content from...' in the email
3.
Actual Results:  
A dialog comes up asking where to add the contact should be added

Expected Results:  
The images should display without the need for accepting if the user is in your address book... If the user is not in your address book it should give you the option of adding it to the system address book, the thunderbird address book, or collected contacts... System address book is missing from the list...

Comment 1

6 years ago
These notes may or may not be related, useful:  http://goo.gl/vqMrw

Comment 2

5 years ago
I like this suggestion - it would address the more annoying bug discussed in <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=741158">741158</a> (and in hydrostarr's link above).

Comment 3

4 years ago
As the behavior for remote content is completely changed in Thunderbird 31 (see bug 457296 ), I consider that this bug is no more valid.
Please comment if you think I am wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.