Mozilla Firefox will not start if nscd isn't running

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: Robert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/531.0 (KHTML, like Gecko) Chrome/3.0.183.1 Safari/531.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090909 SUSE/3.5.3-3.1 Firefox/3.5.3

We are running NIS.
We are running nscd.
We are running OpenSuSE 11.1
This bug appears to be happening on firefox 3.0.x till firefox 3.5.x, no exceptions in rusults.
Firefox tends to stall for sometime (while running nscd) but non-predictable (so it seems)
If I start firefox while nscd is running and later on stop nscd, firefox keeps on running
(but a bit slower)

stoeidoos:~/Desktop> sudo rcnscd restart
stoeidoos:~/Desktop> firefox 
*** nss-shared-helper: Using shared location /home/robert/.pki/nssdb
stoeidoos:~/Desktop> sudo rcnscd stop
firefox: nss_nis/nis-netgrp.c:75: _nss_nis_setnetgrent: Assertion `malloc_usable_size (netgrp->data) >= len + 1' failed./usr/bin/firefox: line 128:  8596 Aborted                 $MOZ_PROGRAM "$@"
stoeidoos:~/Desktop> sudo rcnscd restart
stoeidoos:~/Desktop> firefox 
*** nss-shared-helper: Using shared location /home/robert/.pki/nssdb

etc.....

It seems to me that firefox has become depended on nscd while starting up. I don't think this is good.

Reproducible: Always

Steps to Reproduce:
1. Stop nscd
2. Start firefox
3. crash with:
firefox: nss_nis/nis-netgrp.c:75: _nss_nis_setnetgrent: Assertion `malloc_usable_size (netgrp->data) >= len + 1' failed./usr/bin/firefox: line 128:  8596 Aborted                 $MOZ_PROGRAM "$@"
Actual Results:  
firefox: nss_nis/nis-netgrp.c:75: _nss_nis_setnetgrent: Assertion `malloc_usable_size (netgrp->data) >= len + 1' failed./usr/bin/firefox: line 128:  8596 Aborted                 $MOZ_PROGRAM "$@"

Expected Results:  
1. Stop nscd
2. Start firefox
A running firefox.

Updates via the normal (factory) repositories from suse have all been done with no succes. 
I work as a sys-admin at the Leiden University of Advanced Computer Science. All my students and profs are complaining. All suffer from the same bug. Some people maintain their own computer some are maintained by us (sysadm). All have in common, they use NIS. NIS has been updated to the latest and greatest.
The error seems to point to NIS although the bug is triggered via nscd.
(Reporter)

Comment 1

9 years ago
It seems firefox 3.0.14 was not affected at all (sorry for that)
(Reporter)

Comment 2

9 years ago
I think it's related to [Bug 521551, OPENSUSE BUG LIST!!!!] titled "Unable to start MozillaFirefox" (visit URL: http://lists.opensuse.org/opensuse-bugs/2009-08/msg05116.html )
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.