Closed Bug 529099 Opened 10 years ago Closed 9 years ago

Always show urlbar while loading pages

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 537717

People

(Reporter: stechz, Unassigned)

Details

If page is loading, show url bar.
I think Ben is asking for the URLBar to be visible at all times while a page is loading. For example, if you load a new page and start panning down the page. The URLBar would be visible as long as the page was loading, then disappear after the page completes loading - since you are no longer at the top of the page.

Not sure I agree with this though
OS: Mac OS X → All
Hardware: x86 → All
Yeah, I'm not sure either.  Other mobile browsers do this (mobile safari, android browser) -- the value is that you see that the page is still loading.  You can get a lot of that feedback by seeing the tiles fill in, though, and floating the URL bar consumes some screen space.

A related problem that's definitely worth attention is the one about getting quicker feedback (in the form of the url bar, probably) on starting to load a new page. Bug 537717.
Actually, it doesn't have to be that significant of a change from our current behavior.

After a certain point during page load (I think it's onLocationChange) we scroll content up to the very top.  We could unfloat the url bar then so that pages that get stuck loading aren't always showing the URL bar.

Getting instant feedback that a link click occurred is the important thing to get right IMO.
is this a dupe of (or better handled by) bug 537717?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537717
You need to log in before you can comment on or make changes to this bug.