Regression: Controls are slightly pannable

VERIFIED FIXED in fennec1.0

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: stechz, Assigned: vingtetun)

Tracking

Trunk
fennec1.0
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
When panning a page with a sidebar open, the sidebar controls will move a few pixels.
(Reporter)

Comment 1

9 years ago
Only happening for me on the N900.
I can confirm this on build:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b3pre) Gecko/20091116 Firefox/3.6b4pre Fennec/1.0b6pre

Updated

9 years ago
tracking-fennec: --- → 1.0+
Vivien - Bug 529236 has a patch to fix this bug and another. Even we land the patch in bug 529236, should we still take this patch because it's more robust than the current code?
(In reply to comment #4)
> Vivien - Bug 529236 has a patch to fix this bug and another. Even we land the
> patch in bug 529236, should we still take this patch because it's more robust
> than the current code?

This patch also fix both bugs :)

I think it is more robust because the patch didn't rely on container.top which can be misleading.
Comment on attachment 412723 [details] [diff] [review]
Patch

Since this patch fixes both bugs and doesn't relay on delaying code, I think this would be the better fix.
Attachment #412723 - Flags: review?(mark.finkle) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/906c4c1ccb97
Assignee: nobody → 21
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b3pre) Gecko/20091118 Firefox/3.6b4pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091118 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.