Last Comment Bug 529131 - Can't create / add rss or newsserver accounts from account central
: Can't create / add rss or newsserver accounts from account central
Status: RESOLVED FIXED
: regression, uiwanted
Product: Thunderbird
Classification: Client Software
Component: Account Manager (show other bugs)
: Trunk
: All All
: -- minor (vote)
: Thunderbird 24.0
Assigned To: alta88
:
Mentors:
https://groups.google.com/forum/?from...
: 868824 (view as bug list)
Depends on: 885740 888660
Blocks: 780110
  Show dependency treegraph
 
Reported: 2009-11-16 14:59 PST by Thomas D. (currently busy elsewhere; needinfo?me)
Modified: 2013-07-23 04:38 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (21.85 KB, patch)
2013-05-16 08:11 PDT, alta88
no flags Details | Diff | Splinter Review
account central with account types row (145.46 KB, image/png)
2013-05-16 09:52 PDT, alta88
no flags Details
updated tweaks (23.77 KB, patch)
2013-05-16 13:37 PDT, alta88
bwinton: ui‑review+
Details | Diff | Splinter Review
patch (34.21 KB, patch)
2013-05-17 15:44 PDT, alta88
standard8: review+
bwinton: ui‑review+
Details | Diff | Splinter Review
AC display in win7 (11.96 KB, image/png)
2013-05-21 14:35 PDT, Joe Sabash [:JoeS1]
no flags Details
Broken image layout on mac (27.48 KB, image/png)
2013-06-21 04:27 PDT, Mark Banner (:standard8)
no flags Details

Description Thomas D. (currently busy elsewhere; needinfo?me) 2009-11-16 14:59:57 PST
This looks like a clear case of making the UI worse by trying to streamline and hide everything away just too much.

STR

1 imagine you're an average user and want to setup a news or rss account (as you've heard tb can do that)
2 the most prominent place that looks up to the job is "Create new account" in Account-Central (the screen you get when focus in folder pane is on an account)
3 Try creating your rss / news server from account central
3a) in TB2
3b) in TB3

Actual

3a) in TB2, it's simple and straightforward
- from account central, click "create new account"
- select from "mail account / rss account / google mail / news account"
- be guided through the process step by step

3b) in TB3, it's more difficult
- clicking on "create new account" from account central will always only create a new *mail* account using quick account setup (which is especially weird when you're doing it from account central of an rss account, expecting to create a new rss acoount, or for newsserver account respectively)
- if you're clever, you choose File > New > Mail Account / Other accounts... (what a ridiculous and non-transparent wording for just two more account types that we currently have, can't we just list those two separately?)
- if you're too clever, you might try Tools > Account Settings, there you need to look for the thing like for a needle in the haystack, as it's hidden in "Account Actions > Add other accounts" 

Expected result

3b) "Create new Account" from Account Central should always offer the old screen where you can select the type of account you want to create:
mail / news / rss

We are more than just an email application, why are we hiding TB's full potential?
Comment 1 :aceman 2012-02-11 17:52:24 PST
This is true. It is still the case in TB13. But I do not see any UI that would allow choosing any of the possible account types. It was probably removed or is hidden and on the way out.
Comment 2 alta88 2013-05-02 16:43:57 PDT
bwinton, from the newsgroup post:

Here's my proposal, which I will even implement..

- Account central page (first page shown on clean install), under Create a new account, will show a flex/wrappable row containing:
[icon]Get New mail [icon]Existing mail [icon]Chat
[icon]Newsgroup [icon]Feed [icon]Movemail (ifdef linux)
- Each item will be a link.
- Each link will bring up a dialog/wizard specific to the account type.
- No more general wizard.
- Cancelling Get New Mail wizard will leave the Account Central page in clear view.
- Bonus: get rid of account items in File->New, Appmenu->New Message
Comment 3 alta88 2013-05-06 06:39:46 PDT
*** Bug 868824 has been marked as a duplicate of this bug. ***
Comment 4 alta88 2013-05-07 07:35:55 PDT
From the newsgroup.

---On 2013.May.07 1:34 AM, Mark Banner wrote:> On 02/05/2013 22:10, alta88[nntp] wrote:
> 
> Probably need to see what it looks like in real life, but I think we 
> could just have mail accounts as one item. Might need a slight tweak on 
> the get new email wizard to make the existing button more obvious, but I 
> think having two buttons may be a bit much.
> 

I would like confirmation that this is a direction that will be accepted, before doing the work.  Namely, that all supported account types will be visible on Account Central and 1 click opens their specific dialogs/wizards.  (Feeds may not even need the name collection dialog, I'm split whether it should be offered but lean toward yes).

Yes, 1 for mail is better than 2.  

>> - Each item will be a link.
>> - Each link will bring up a dialog/wizard specific to the account type.
>> - No more general wizard.
>> - Cancelling Get New Mail wizard will leave the Account Central page in
>> clear view.
>> - Bonus: get rid of account items in File->New, Appmenu->New Message
> 
> I don't quite see the rationale for getting rid of these menu items. 
> Some users like to have these available, rather than having to click 
> through windows/dialogs. I guess I'd need to see the full flow to 
> understand what you're thinking about here.
> 

Well, this is optional.  But I don't think anyone will go into those tiny, multi flyout menuitems (it's 3 flyouts and 2 clicks for mail/chat, 3 for news/feeds) once a nice large linkable item is available in AC.

Plus, they're a UX mess, imo.  A disunified patchwork.  And with code replicated twice.  Isn't removing a piece of the menuitem tangle a worthy goal?

It's a significant simplification and I think users will understand accounts are created from:
1)Account Central page
2)Edit|Tools -> Preferences|Options -> Account Settings

> Mark.
Comment 5 alta88 2013-05-07 07:45:48 PDT
It's actually:

2)Edit|Tools -> Account Settings
Comment 6 Blake Winton (:bwinton) (:☕️) 2013-05-14 13:34:46 PDT
alta88: I think this sounds good.  Is there any way you could make a quick mockup, showing the screen flow on startup, and listing/showing each of the ways the user could hit the new screens, so that I can double-check that I understand all of what you're proposing?

Thanks,
Blake.
Comment 7 alta88 2013-05-16 08:11:30 PDT
Created attachment 750460 [details] [diff] [review]
patch


this is pretty much it.

1. osx styling is likely close, but will need final tuning from a pro (ie someone with a mac).
2. ispdata: core Tb ships with only rss and movemail generating rdf based templates; real isp data files for mail were briefly used and are now deprecated in favor of the current provisioner, afaict.
3. rss account creation is 1 click now.  newsgroups/movemail use the existing wizard and autoselect the desired type, then advance the wizard.
4. menuitems are gone, it no longer feels onerous/unpleasant to hit upon file->new.
Comment 8 Blake Winton (:bwinton) (:☕️) 2013-05-16 09:14:20 PDT
Is there any chance you could attach some screenshots to help me with the ui-review?

Thanks,
Blake.
Comment 9 alta88 2013-05-16 09:52:54 PDT
Created attachment 750510 [details]
account central with account types row


sure.

clicking email brings up the existing provisioner; chat brings up the existing create chat account wizard; newgroups/movemail brings up the old account wizard dialog with that radio selected and advanced a page; feeds automatically creates the account with the default name (no wizard) and selects it.
Comment 10 Blake Winton (:bwinton) (:☕️) 2013-05-16 11:57:30 PDT
That looks pretty good.  A couple of things I'ld like to see changed…
1) Line up the icon with the text of the top row.
2) Put a ":" at the end of the text of the top row.

I'll do a fuller ui-review later, but like I said, it looks pretty good…

Thanks,
Blake.
Comment 11 alta88 2013-05-16 13:37:44 PDT
Created attachment 750652 [details] [diff] [review]
updated tweaks
Comment 12 rsx11m 2013-05-16 13:54:02 PDT
Do we really want to remove those options from the "regular" menus?

Despite "Create a new account" having been in the Account Central page before, there was still the option to create if from the menu instead whenever you felt like it. Now, you'd have to go to Account Central first and click the respective account type there, if I read your patch correctly.
Comment 13 rsx11m 2013-05-16 14:05:45 PDT
Ah, I see, you gave the reasoning in comment #4. As for the File > New submenu from the "real" menu bar, I wouldn't see it as a "UI mess" for that matter; those entries aren't disrupting in any way. From the application button, it may be a different story, given that they are grouped under the "New Message" menuitem; I'd agree that they indeed look misplaced there (unless that menu is renamed to just "New" to match its counterpart).
Comment 14 alta88 2013-05-16 14:24:09 PDT
Yes, both File and Appmenu menuitems should definitely be removed, and in a followup I'd like to also remove the account creation menuitems from the bottom of the Account Settings tree.

As someone (coughbwintoncough) said, it is an rare activity to set up a new account.  However, as a new user must first interact with a new account setup, it should be easy and look attractive.  There should be one and only one place to initiate setup - the eponymous Account Central, which can even be enhanced to be more html5 like.  Multiple menuitems are none of that.

jmo.
Comment 15 :aceman 2013-05-16 14:30:14 PDT
On the other hand, will the users know how to get to the account central when they need a new account? Users I observed never use/see the account central page. I don't think removing it from Account settings is good.
Comment 16 alta88 2013-05-16 15:07:33 PDT
I'd guess many more average users have been in Account Central than have ever been in Account Settings.  And noticed that Account Actions button.

In general, I think it's fairly obvious popup windows are declining in modern design.  It would be a positive goal to actually move those settings into the 3pane AC page, which is extremely underutilized.
Comment 17 Ian Neal 2013-05-16 15:09:59 PDT
Comment on attachment 750652 [details] [diff] [review]
updated tweaks


>+++ b/mailnews/base/content/msgAccountCentral.xul
>@@ -36,16 +36,20 @@
>   <script type="application/javascript"
>           src="chrome://messenger/content/mailWindow.js"/>
>   <script type="application/javascript"
>           src="chrome://messenger/content/msgMail3PaneWindow.js"/>
>   <script type="application/javascript"
>           src="chrome://messenger/content/widgetglue.js"/>
>   <script type="application/javascript"
>           src="chrome://messenger/content/msgAccountCentral.js"/>
>+  <script type="application/javascript"
>+          src="chrome://messenger/content/mailCore.js"/>
This only exists in TB not SM, so shouldn't this be ifdef'd out too?


>+++ b/mailnews/base/prefs/content/accountUtils.js
>@@ -176,33 +176,48 @@ function MsgAccountWizard(wizardCallback
> }
> 
> /**
>  * Open the Old Mail Account Wizard, or focus it if it's already open.
>  *
>  * @param wizardCallback if the wizard is run, callback when it is done.
>  * @see msgNewMailAccount below for the new implementation.
The extra param needs adding to the comment.
>  */
>+function msgOpenAccountWizard(wizardCallback, type)
Comment 18 Jim Porter (:squib) 2013-05-16 15:55:39 PDT
(In reply to alta88 from comment #16)
> In general, I think it's fairly obvious popup windows are declining in
> modern design.  It would be a positive goal to actually move those settings
> into the 3pane AC page, which is extremely underutilized.

There's already a goal to drastically change Account Central: bug 489999. It's been a long process, but I've been iterating on Mail Summaries for a while now, and it's relatively close to being good enough to land in Thunderbird. The account summary, however, focuses much more on the current account, not on creating new accounts, since that's a pretty rare action.

While it's possible to include some account creation options in the account summary, I don't think that the summary for an existing account is the most obvious place to look for creating a *new* account. The most obvious place would be account settings.

We can certainly work to improve the account settings dialog, though. It would be really nice to replace it (and the options dialog) with a single tab holding all the application's preferences. If such a tab existed, we could make sure to prominently show account creation options there, which seems to me the most sensible place for them.
Comment 19 alta88 2013-05-16 16:25:04 PDT
(In reply to Jim Porter (:squib) from comment #18)
> (In reply to alta88 from comment #16)
> 
> While it's possible to include some account creation options in the account
> summary, I don't think that the summary for an existing account is the most
> obvious place to look for creating a *new* account. The most obvious place
> would be account settings.
> 

It's not clear if your comments bear on this bug or are informational, but I would say the most obvious place to look, upon a new install, to do something useful with Tb is the AC page right in front of the user.

After that, it would be clacking around to find a File->New or such menuitem, which has proven difficult (with the menubar hidden) for people who don't want the email provisioner.  Pretty much the last place anyone is going to find is Account Settings->Account Actions.

Anyway, all that's needed is a simple to find 1 line of icons in an obvious place, which is all this patch does.  It's merely a further discussion on whether new account menuitems should remain, in multiple places (and I think not).
Comment 20 Joe Sabash [:JoeS1] 2013-05-16 16:44:55 PDT
(In reply to alta88 from comment #19)
> 
> Anyway, all that's needed is a simple to find 1 line of icons in an obvious
> place, which is all this patch does.  It's merely a further discussion on
> whether new account menuitems should remain, in multiple places (and I think
> not).

I think those menuitems should remain for now.
Because even worse than a new user experience, might be an old user experience not finding his "discovered" ways to do what he wants.

Those changes should be followup IMO
Comment 21 Blake Winton (:bwinton) (:☕️) 2013-05-16 19:38:43 PDT
Comment on attachment 750652 [details] [diff] [review]
updated tweaks

On Mac, the bottoms of the icons on the second row seem to be cut off.
https://dl.dropbox.com/s/n11r0r9ucyhfafy/TBNewAccount.png

I think I agree that we shouldn't take away the menu items quite yet.  (The reason the menu item is named "New Message" instead of just "New", is so that people can click it to get a new message, or click the disclosure arrow to get the New menu…)

Aside from that, the only other two things I would ask for is that the "Feeds" gets renamed to "Blogs & News Feeds", and that we pop up a modal dialog to ask people what they want to name the new item.  (I know, modal dialogs are _not_ the future, but let's get a small change in that improves stuff, and then make the rest of the changes in followup bugs.)

ui-r=me with those four things fixed.

Thanks,
Blake.
Comment 22 :aceman 2013-05-16 23:35:39 PDT
(In reply to alta88 from comment #19)
> It's not clear if your comments bear on this bug or are informational, but I
> would say the most obvious place to look, upon a new install, to do
> something useful with Tb is the AC page right in front of the user.

Upon new install I agree as AC is forced on the user so he can't miss it. But when he already has an account, he may never figure to click the account name in the folder pane.
Comment 23 Thomas D. (currently busy elsewhere; needinfo?me) 2013-05-17 00:07:27 PDT
(In reply to :aceman from comment #22)
> (In reply to alta88 from comment #19)
> > It's not clear if your comments bear on this bug or are informational, but I
> > would say the most obvious place to look, upon a new install, to do
> > something useful with Tb is the AC page right in front of the user.
> 
> Upon new install I agree as AC is forced on the user so he can't miss it.
> But when he already has an account, he may never figure to click the account
> name in the folder pane.

I haven't followed this very closely, but ftr I agree with the many voices on this bug who are sceptical against removing account creation options from the file > new menu or tools > account options. Surely improvements in that corner are possible, but they should be discussed and done in another bug, including consideration of ux-discovery and accessibility issues (And btw I never saw a problem with the old dialogue where users could choose the type of the new account on the first page of the wizard. I don't see much of a multiple flyout problem either, since account creation doesn't happen every day, and that multiple flyout problem looks more like a general app menu problem to me because app menu always adds one click.)
Comment 24 alta88 2013-05-17 07:39:37 PDT
The other reason for getting rid of menuitems and centralizing account creation in one place is to begin to remove dependency on the original Account Wizard, for the unfortunate victims stuck in the Other category.  For feeds, bugs are:
1) bug 797412: remove rss.rdf from Tb, only used to get 1 string.
2) bug 780110: fix is to use the newer codepath, already in Import and this patch.

So if menuitems stay, feeds need to come out of Other and into their own menuitem, in 3 places, to accomplish the above.  Blake, will you agree to this?  ;)
Comment 25 Blake Winton (:bwinton) (:☕️) 2013-05-17 07:43:22 PDT
Yeah, I'ld be up for changing "Other".  But, check with rkent first to see how this affects him, since he's the only person I know of who added a new account type…
Comment 26 alta88 2013-05-17 08:24:09 PDT
It wouldn't change Other the menuitem or affect how any account in Other is handled in the old Account Wizard, merely add a separate menuitem/path for feeds.  Plus, his twitter account type is already a separate, and nice menuiconic, menuitem.
Comment 27 Kent James (:rkent) 2013-05-17 15:24:26 PDT
In ExQuilla, I don't put adding an account under "Other", but on the same level as "Add Mail Account". (Same way on the File/New submenu). So merely removing the "Other" IU element would not affect me.

I do however use the Account Wizard, but it is an extremely confusing piece of code.
Comment 28 alta88 2013-05-17 15:41:22 PDT
(In reply to Kent James (:rkent) from comment #27)
> In ExQuilla, I don't put adding an account under "Other", but on the same
> level as "Add Mail Account". (Same way on the File/New submenu). So merely
> removing the "Other" IU element would not affect me.
> 
> I do however use the Account Wizard, but it is an extremely confusing piece
> of code.

That's why I'm ripping feeds out of it, and they will join you there.  Btw, new account types are hard solely due to the way compiled code loads xul in Account Settings, if only new accounts didn't have to live in that neighborhood..
Comment 29 alta88 2013-05-17 15:44:46 PDT
Created attachment 751248 [details] [diff] [review]
patch


updated with a small wizard and menuitems, thus removing feeds from old Account Manager.  btw, the 'links' in Account Central are tab stops, link colored when focused, and activated upon <enter>.
Comment 30 Kent James (:rkent) 2013-05-17 17:42:46 PDT
(In reply to alta88 from comment #28)

> Btw,
> new account types are hard solely due to the way compiled code loads xul in
> Account Settings, if only new accounts didn't have to live in that
> neighborhood..

New account types are hard for many, many reasons beyond Account Settings.
Comment 31 alta88 2013-05-20 11:17:12 PDT
Blake, regarding the AC label..  I really think is should be the short name Feeds, do you feel strongly about it?

1) It's shorter (en).
2) It's consistent with menuitems and the large heading label in AC, which is also consistent with other account types.
3) The long name is autosuggested in the wizard anyway.
4) It's not a good long name.  If you scan support places, "it" is almost universally referred to as "rss feeds" or "feeds" or "rss".
Comment 32 Joe Sabash [:JoeS1] 2013-05-21 14:35:30 PDT
Created attachment 752387 [details]
AC display in win7

FWIW I imported this patch to a local build.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.0a1 ID:20130519163206 CSet: 6c605636afe1
Checked that the new links worked as advertised, and the old menu methods worked as well.
I see no reason that approvals/checkin shouldn't move forward.
Comment 33 Blake Winton (:bwinton) (:☕️) 2013-05-21 19:32:54 PDT
alta: Yeah, okay, you've convinced me to stick with "Feeds".
Comment 34 Blake Winton (:bwinton) (:☕️) 2013-06-03 08:14:14 PDT
Comment on attachment 751248 [details] [diff] [review]
patch

Sorry, forgot to mark this ui-r=me…

Thanks,
Blake.
Comment 35 Mark Banner (:standard8) 2013-06-21 04:26:27 PDT
Comment on attachment 751248 [details] [diff] [review]
patch

Review of attachment 751248 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. There's one minor issue on Mac with the icons - I think the sizes might be wrong in the css file. I'll attach a screenshot, if possible it'd be nice to fix that before landing, but as TB 24 branches on Monday, I don't mind landing this first and fixing that after.
Comment 36 Mark Banner (:standard8) 2013-06-21 04:27:06 PDT
Created attachment 765887 [details]
Broken image layout on mac
Comment 37 alta88 2013-06-21 07:56:59 PDT
looks like it's a 2x icons issue on mac, i'll see about a followup.
Comment 38 Ryan VanderMeulen [:RyanVM] 2013-06-23 17:40:53 PDT
https://hg.mozilla.org/comm-central/rev/85e3260d4e63

Note You need to log in before you can comment on or make changes to this bug.