Undefined subroutine &Bugzilla::Util::ThrowUserError

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: khuey, Assigned: reed)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

I entered "-1 day" in the timeframe box for a date changed search (I was guessing at the syntax) and got the following error

"Software error:

Undefined subroutine &Bugzilla::Util::ThrowUserError called at /data/www/bugzilla.mozilla.org/Bugzilla/Util.pm line 680.

For help, please send mail to the webmaster (bugzilla-admin@mozilla.org), giving this error message and the time and date of the error."

No idea if this is new with the upgrade, as I've never tried it before (always used the "view bugs filed in the last day" link which seems to be gone).
(Assignee)

Comment 1

8 years ago
Created attachment 412732 [details] [diff] [review]
patch - v1
Assignee: nobody → reed
Status: NEW → ASSIGNED
Attachment #412732 - Flags: review?(LpSolit)
(Assignee)

Updated

8 years ago
Component: Bugzilla: Other b.m.o Issues → Bugzilla-General
OS: Windows NT → All
Product: mozilla.org → Bugzilla
QA Contact: other-bmo-issues → default-qa
Hardware: x86 → All
Target Milestone: --- → Bugzilla 3.4
Version: other → 3.4.3

Comment 2

8 years ago
Comment on attachment 412732 [details] [diff] [review]
patch - v1

No, this causes dependency loops. And it's a dupe anyway.
Attachment #412732 - Flags: review?(LpSolit) → review-

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 3.4 → ---
Duplicate of bug: 360626

Comment 4

8 years ago
Wait, this error comes from SqlifyDate(), which doesn't exist upstream in Util.pm. It's a bmo bug.
Assignee: reed → nobody
Status: RESOLVED → REOPENED
Component: Bugzilla-General → Bugzilla: Other b.m.o Issues
Product: Bugzilla → mozilla.org
QA Contact: default-qa → other-bmo-issues
Resolution: DUPLICATE → ---
Version: 3.4.3 → other
(Assignee)

Comment 5

8 years ago
Created attachment 412736 [details] [diff] [review]
patch - v2
Assignee: nobody → reed
Attachment #412732 - Attachment is obsolete: true
Status: REOPENED → ASSIGNED
Attachment #412736 - Flags: review?(justdave)
Blocks: 528846
(Assignee)

Updated

8 years ago
Duplicate of this bug: 529562

Comment 7

8 years ago
Comment on attachment 412736 [details] [diff] [review]
patch - v2

>+        require Bugzilla::Error;
>         ThrowUserError("illegal_date", { date => $str });

If you |require Bugzilla::Error| instead of use'ing it, ThrowUserError() is not imported and so it's still unknown to Bugzilla::Util. You have to write Bugzilla::Error::ThrowUserError() explicitly, despite the |require|.
Attachment #412736 - Flags: review?(justdave) → review-
(Assignee)

Comment 8

8 years ago
Created attachment 413107 [details] [diff] [review]
patch - v3
Attachment #412736 - Attachment is obsolete: true
Attachment #413107 - Flags: review?(LpSolit)

Comment 9

8 years ago
Comment on attachment 413107 [details] [diff] [review]
patch - v3

r=LpSolit
Attachment #413107 - Flags: review?(LpSolit) → review+
modified Bugzilla/Util.pm
Committed revision 6718.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
this is now live in production.
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.