drag drop of html file fails

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: tds, Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

Dragging a local html file sitting in a directory into SeaMonkey
results in a blank page.

Reproducible: Always

Steps to Reproduce:
1. Set up any html file.
2. Drag the file into a SeaMonkey window

Actual Results:  
Sometimes the page becomes blank.


Expected Results:  
The page should show of course.

This failed for me just now so there must be another factor.  I made a file
x.html with only three lines:

<html>
something
</html>

and dragged and dropped it - but it showed.  It's not clear why this bug
occurs sometimes and not others.

Comment 1

9 years ago
I suspect this is not an application-specific issue, but I could be wrong - can you see if this happens in Firefox (3.5.x) as well?
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)

Good question.  Since SeaMonkey is my main browser and I didn't want to switch,
I put my mouse on the file and right clicked and then selected Open With
to chose browsers.  SeaMonkey failed.  Firefox 3.5.4 succeeded. Safari 4.0.4 succeded.  Answer: it is application specific and even the latest version of SeaMonkey specific since previous versions did not do this.
Version: unspecified → SeaMonkey 2.0 Branch

Comment 3

8 years ago
Does it only fail with drag and drop? How about File->Open with the same file?

Any relevant errors in the Error Console?
Tools->Web Development->Error Console
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> Does it only fail with drag and drop? How about File->Open with the same file?
> 
> Any relevant errors in the Error Console?
> Tools->Web Development->Error Console

Thanks for raising this.  I can't reproduce it anymore.  It's been nearly 2 years and I don't recall the file that gave me the problem. A simple file works and a pretty complex one did too.  So I am going to change the status to Resolved WORKSFORME.  If it comes up again I'll make a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.