when calling images from inside of flash objects in firefox,web server can't get %{HTTP_REFERER}

RESOLVED DUPLICATE of bug 410904

Status

()

--
major
RESOLVED DUPLICATE of bug 410904
9 years ago
8 years ago

People

(Reporter: xiancool2000, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

178.23 KB, application/force-download
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Enable apache prevent-hotlink feature
other site will not be able to call image

but you can call images within your own website which apache host

if a page within a site you can successfully call images
but you can't calling images from inside of flash objects only in firefox
IE&chrom works well, can calling images from inside of flash object. 




Reproducible: Always

Steps to Reproduce:
1.enable apache prevent-hotlink feature
2.download http://www.greatwallhiking.com/pageFirefoxBugExample.rar 
3.uncompress file and put it under your apache site folder
4.visit index.html,you can't see the flash rotating images in firefox3.5
5. it's firefox's but,ie&chrome can display flash rotating images 
Actual Results:  
you can't see the flash rotating images in firefox3.5

Expected Results:  
Flash can rotating images in firefox
(Reporter)

Comment 1

9 years ago
Created attachment 412777 [details]
example for reproduce the bug

Updated

9 years ago
Component: Disability Access → General
QA Contact: disability.access → general
(Reporter)

Comment 2

9 years ago
flash load images 
web server,apache
can't get %{HTTP_REFERER} 

but In Microsoft internet explorer when calling a image from inside of flash
web server can get %{HTTP_REFERER}
Summary: apache prevent-hotlink feature is not compatible when calling images from inside of flash objects → when calling images from inside of flash objects in firefox,web server can't get %{HTTP_REFERER}

Comment 3

8 years ago
duplicate of 410904

https://bugzilla.mozilla.org/show_bug.cgi?id=410904

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410904
You need to log in before you can comment on or make changes to this bug.