The page is not being drawn correctly

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P3
normal
VERIFIED FIXED
18 years ago
3 years ago

People

(Reporter: Mike Cordeiro, Assigned: zach)

Tracking

({testcase})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20000907
BuildID:    2000090708

Everything on the page appears to be correct, except for a small box placed in
the centre of the screen listing all the sports at the olympics. This covers the
underlying text and images

Reproducible: Always
Steps to Reproduce:
1. Visit www.olympics.com
2. Wait until the page loads
3.

Actual Results:  The same error occured.

Expected Results:  Drawn the page without the centre box listing of all the
events

Comment 1

18 years ago
I'm seeing this problem on PC/Linux build 2000091521. The box (map?) with all
the spors in the center of the page is displayed in Mozilla, but not in NN 4.x.
But since the site is doing a lot of browser- and version- sniffing, I'm not
sure that this is not a problem in the page itself. Maybe a reduced testcase
would help.

Comment 2

18 years ago
Created attachment 14866 [details]
testcase

Comment 3

18 years ago
I have isolated the "sport chooser" into a testcase. The problem is that it
assumes that either document.layer or document.all is working. e.g.:

function show(object) {
if (document.layers && document.layers[object] != null)
document.layers[object].visibility = 'visible';
else if (document.all)
document.all[object].style.visibility = 'visible';
}

They should be using document.getElementByID instead (W3C DOM level 1).
See http://sites.netscape.net/ekrock/standards.html.
Reassiging to Evangelism.
Assignee: clayton → blakeross
Component: Layout → Evangelism
Keywords: evangwanted, testcase
QA Contact: petersen → zach

Comment 4

18 years ago
*** Bug 53784 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

18 years ago
Letter sent. Assigning to self
Assignee: blakeross → zach
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: evangwanted
(Assignee)

Comment 6

18 years ago
stupid whine mail!
Status: NEW → ASSIGNED
(Assignee)

Comment 7

17 years ago
*** Bug 55356 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
page no longer exists but i cruised around the olympic site using
2001-060-05-04/win2k and did not see any obvious problems or js console errors
related to layers, so marking fixed. 
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
verifying (but should have been marked invalid)
Status: RESOLVED → VERIFIED

Comment 10

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.