Unable send a file with an attachment with a non-English file name

RESOLVED DUPLICATE of bug 470700

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 470700
9 years ago
8 years ago

People

(Reporter: jubinell, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: version 2.0.0.23 (20090812)

Hi,

When you attach file to Thunderbird if it contains non-English characters, if you try to send such a message you'll get the following error message:

"Unable to open the temporary file....check your 'Temporary Directory' setting.

Reproducible: Always

Steps to Reproduce:
1. Compose a new message
2. Click on the Attachment button
3. Choose a file with a foreign file name. For example: "日本語".
4. Click OK
5. Try to send the file

Actual Results:  
The error message appears.

"Unable to open the temporary file....check your 'Temporary Directory' setting.

Expected Results:  
Send the message successfully.

Temporary solutions:

1) Change the file name to English characters only.
2) Change system locale to the language that supports the characters that are creating the problem

Both of these aren't great solutions. 1) for example is unprofessional. I don't want to send an attachment to a Japanese client and have to explain to him how I changed the document's official name to some English equivalents that he/she doesn't understand. 2) is so-so but if you have other non-English programs installed, their texts will start to look weird since they are being viewed through the Japanese locale.
Yes it is an issue that affect TB 2.x but that is solved in TB 3.x.
See bug #470700  for details. Close as dupe of bug #470700.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470700
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0
You need to log in before you can comment on or make changes to this bug.