Closed Bug 529255 Opened 10 years ago Closed 6 years ago

Web Page attachment doesn't work if it has a redirection

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 204250

People

(Reporter: jmordax, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 (CK-IBM) Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091112 Thunderbird/3.0

Try to attach http://www.google.com to a new message.
It doesn't show anything when you receive the message. I suspect it is because google.com redirects in my case to http://www.google.es
If I attach htt://www.google.es instead of http://www.google.com the page is shown in the received message.

Don't know if this is really a bug, or if redirections are not supported.

Reproducible: Always

Steps to Reproduce:
1.Start a new message
2.Attach a Web Page like http://www.google.com
3.Send the message
4.The received message is blank.
Confirming regression. This seems to be an error in sending rather than receiving.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
This bug also can be reproduce on Solaris + Thunderbird 3.0.1. 

The steps we reproduce is as below: 
1.Start a new message
2.Attach a Web Page like http://www.sun.com (Actually, the www.sun.com will redirect to http://www.oracle.com/index.html)
3.Send the message
4.The received message will lost the attachment.
Version: unspecified → 3.0
Still present in
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.7) Gecko/20100713 Thunderbird/3.1.1

This is an awful bug.  I lost a ton of work due to it.
Q: When is a mail archive not a mail archive?
A: When all the attachments are missing, and *no error message of any type* is reported to indicate failure to perform a requested action.
See Also: → 501298
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 204250
You need to log in before you can comment on or make changes to this bug.