If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Username/Password dialogue for proxy settings on every page since Firefox 3.6b1

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Tobi, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2 (.NET CLR 3.5.30729)

I'm using a proxy to connect to the internet.
Last week I tried the second beta of Firefox 3.6.
First I configured the proxy settings. After that I opened a few websites. For each website I got a dialogue with the request of username and password. Now it works, but if I follow a link the dialogue appears again and again.

Reproducible: Always

Steps to Reproduce:
Open a website through a proxy.
Actual Results:  
Firefox always asks for username and password.

Expected Results:  
Ask once and store the settings as Firefox 3.5 and beneath.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 1

8 years ago
Problem gone with beta 3
resolving WFM in this case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 3

8 years ago
as for me, the problem is not gone with firefox 3.6 beta 3. In Firefox 3.5.5, it was still possible to solve the problem by setting the 'network.negotiate-auth.allow-proxies' to 'false'. But this does not work anymore in Firefox 3.6 Beta 3.

Comment 4

8 years ago
I also have the same problem with FireFox 3.6 Beta 3. 

To help you in finding the root of the problem :

- I think (but I am not sure) that the problem appeared for me between Beta 2 and Beta 3. 
- The problem only appears when I am at one specific customer site, where I have to manually set the proxy to a specific value on port 8080. 
- For all others places where I simply use the "auto-detect" mode, everything works fine.
- I don't use FoxyProxy.

Comment 5

8 years ago
- I use a manually set proxy on port 8080 as well.
- I don't use any proxy-addons also, using them doesn't change the behaviour though.

Comment 6

8 years ago
Since I've updated my Firefox with [Help - Search for Updates] to the new version 3.6 I've also the problem.
Firefox asks me on every page to confirm my username & password.

Setting the "network.negotiate-auth.allow-proxies" to "false" in the about:config does not help. Before 3.6 it worked this way.

Comment 7

8 years ago
I reported that I had this issue with 3.6 Beta 3. It is still present in the final 3.6 version.

Comment 8

8 years ago
Problem solved!
Search in the about:config for "ntml"... you will find: 
"network.automatic-ntlm-auth.allow-proxies"... default setting is true, change it to false.
Restart FF, now Firefox asks you only 1 time for auth.

Comment 9

8 years ago
Thanks Markus, this also solved my problem.

Question to the FireFox team : is it acceptable that the solution to such a problem is to change the config in "about:config" ? I don't think we would want regular users to do this...
You need to log in before you can comment on or make changes to this bug.