Closed Bug 529384 Opened 12 years ago Closed 12 years ago

XML parsing errors in content area going between sites

Categories

(Core :: Layout, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 368909

People

(Reporter: jaas, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot 1
Recently on trunk I've been seeing XML parsing errors flash in the HTML content area when navigating between two sites. I think it happens when I move from one site to another while the former site is still loading but I'm not sure. I often see it when I'm on or going to planet.mozilla.org and macworld.com.

The error flashes just briefly but I caught it once for a screenshot.
planet.mozilla.org is sent as application/xhtml+xml.

If you interrupt its load, the XML parser detects that as missing closing tags and reports that (bug 368909).  The load is interrupted when the load of a new site starts.  So if the new site takes long enough to actually load, you'll see the XML error screen.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368909
You need to log in before you can comment on or make changes to this bug.