During "attach file(s)" sudden modal dialog warning renders all "ok" buttons broken, hangs TB

RESOLVED DUPLICATE of bug 448452

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 448452
9 years ago
9 years ago

People

(Reporter: Graham Leggett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB5
Build Identifier: 

Thunderbird has some broken UI on the Mac where unprovoked warnings are randomly popped up as modal dialog boxes, stealing focus from the user and forcing the user to click "OK" to acknowledge them.

To create such a warning, let a digital certificate expire. The warning will pop up every time TB tries to save a draft on disk.

This unwanted warning triggers a TB hang.

Create a new mail, and wait for the unproved warning to appear about being unable to save the message as draft.

Create a second mail, and open the "attach files" dialog, and leave this dialog open.

After some time, the unproved dialog pops up in the first mail. At this point none of the OK buttons work, and TB is locked up. All unsaved email is lost.

To fix this, the unprovoked dialog boxes should *not* be generated when other modal dialogs are already present.

Even better, the modal dialogs should be canned completely in favour of the boxes that appear to the right of the screen to notify the end user of events without disturbing the focus of the end user, as used by Skype and other chat clients for notifying of incoming messages.


Reproducible: Always

Steps to Reproduce:
xxx
(Reporter)

Comment 1

9 years ago
While these annoying modal dialog boxes appear, for some reason TB's main menu is greyed out, including the ability to quit.

During the TB stuck state described above, all menu options, including quit, are grayed out. Quit is available from the task bar, but is ignored.

The only way to kill thunderbird is with "force quit".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 448452
You need to log in before you can comment on or make changes to this bug.