View source displays with asian chars, not normal HTML tags.

VERIFIED DUPLICATE of bug 52655

Status

SeaMonkey
UI Design
P3
normal
VERIFIED DUPLICATE of bug 52655
18 years ago
10 years ago

People

(Reporter: Thomas Stromberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When I use view source, rather then seeing the tags in a normal european
charset, like "<HTML>", I see "(lots of strange asian symbols)". Because the
page uses some asian text, mozilla is probably switching language charsets for
the entire duration, including view source.

If you cut and paste the asian chars, they show up as html tags.

This is also reported in Linux builds.
(Reporter)

Comment 1

18 years ago
Created attachment 14861 [details]
Screenshot of what view-source looks like on the page
(Reporter)

Comment 2

18 years ago
The screenshot above uploaded very badly in mozilla. Almost looks like the
classic case of not turning binary mode on in ftp. Here is the screenshot from
my page:

http://home.detachment.org/mozilla-viewsource.jpg

Comment 3

18 years ago
in win32 build 2000091508, view source comes up in english. I can also confirm
this for linux

Comment 4

18 years ago
I'm seeing this with CVS from 091620. If I load the page with Lynx, I see:

Alert!: euc-kr

which presumably means the server is claiming it's in an asian encoding.
Status: UNCONFIRMED → NEW
Ever confirmed: true
teruko?
QA Contact: sairuh → teruko

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 52655 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
marking verified dupe
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.