unnecessary locale detection adds extra locale code in urls on getpersonas

VERIFIED FIXED in 2.0

Status

P1
normal
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

unspecified

Details

(Reporter)

Description

9 years ago
1/ use a browser in locale ab-CD, fr for example
2/ visit getpersonas in another locale like http://www.getpersonas.com/de/

expected result: see the German version
actual result: you are redirected to http://www.getpersonas.com/fr/de/ which is 404

(Tested with Firefox 3.6b3)
(Reporter)

Updated

9 years ago
Blocks: 528943
Target Milestone: --- → 2.0
Wow, really odd considering the only locale supported on getpersonas.com is en-US.
Pascal must be using the French version of Fx.
In the en-US version of Firefox if you go to http://www.getpersonas.com/de/
you are redirected to http://www.getpersonas.com/en-US/de/
(Reporter)

Comment 3

9 years ago
note that this is impacting all 3.6 firstrun/whatsnew pages, would be nice to get that bug fixed soon because I get pinged about that by localizers every day.

Updated

9 years ago
Priority: -- → P1
r57114 should fix this. 

Current expected behavior for all non en-US locales attempting to view a url like:
sm-personas01.mozilla.org/xx/ will be redirected to sm-personas01.mozilla.org/en-US/xx/
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified, FIXED.
Filed Bug 532244 related to this bug.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Component: getpersonas.com → getpersonas.com
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.