Settings for Alarm defaults are ignored when saving events/tasks

RESOLVED INCOMPLETE

Status

Calendar
Lightning Only
RESOLVED INCOMPLETE
8 years ago
8 years ago

People

(Reporter: hawran, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.23) Gecko/20090812 Lightning/0.9 Thunderbird/2.0.0.23 - Build ID: 2009081209

When I get an invitation to an event (a task), I save it to my calendar (by Accepting it). However, I have to set up the reminder for such an event (a task) manually despite the fact my Preference for Alarm defaults are as follows:
Default alarm settings for events: On
Default alarm settings for tasks: On
Default time an alarm goes off before an event: 15 min
Default time an alarm goes off before a task: 15 min

It's really annoying as one must think about it because one can miss his appointment without a reminder.

Reproducible: Always

Steps to Reproduce:
1. Get an invitation to an event (a task)
2. Set up the Alarm defaults to On (plus some times)
3. Accept the invitation
4. Go to the calendar tab, the new invitation is without a reminder
Actual Results:  
The new invitation is without a reminder.

Expected Results:  
There is the new invitation with an alarm according to the Alarm defaults settings.

Generated: Wed Nov 18 2009 09:56:35 GMT+0100 (CET)
User Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.23) Gecko/20090812 Lightning/0.9 Thunderbird/2.0.0.23
Build ID: 2009081209

Enabled Extensions: [4]
- Lightning 0.9: http://www.mozilla.org/projects/calendar/releases/lightning0.9.html
- MR Tech Toolkit 6.0.3.4: http://www.mrtech.com/extensions/
- Talkback 2.0.0.9: http://talkback.mozilla.org/
- České slovníky pro kontrolu pravopisu 1.0.1: http://www.google.com/search?q=Thunderbird%20%u010Cesk%E9%20slovn%EDky%20pro%20kontrolu%20pravopisu

Disabled Extensions: [1]
- British English Dictionary 1.19: http://www.google.com/search?q=Thunderbird%20British%20English%20Dictionary

Total Extensions: 5

Installed Themes: [3]
- Littlebird 1.8.52: https://addons.mozilla.org/en-US/thunderbird/addon/1493/developers
- Noia 2.0 eXtreme 3.13: http://pagesperso-orange.fr/thunderbird-noia2/
- Thunderbird (default): http://www.mozilla.org/

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 450565
(Reporter)

Comment 2

8 years ago
Sorry for my ignorance but I've just realised I've still got the problem I'd described above.

To my great surprise,  the "original" report at https://bugzilla.mozilla.org/show_bug.cgi?id=450565 mentions a fix sometime in year 2008 (Checked in lightning build 20081109044044 -> VERIFIED.).

My question is: how/where is it fixed and I'm experiencing this error?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

8 years ago
You are using Lightning 0.9 that was released September 2008. Bug 450565 was fixed for Lightning 1.0 and validated with a test build from November 2008. You'll have to update to Thunderbird 3.0 and Lightning 1.0b1 to get the fix.
No response for a while now, closing INCOMPLETE. Please reopen if you can reproduce or answer any unanswered questions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.