certain scroll bars in content are non-functional in Zimbra, GMail and Google Docs

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Chris Beard, Unassigned)

Tracking

3.6 Branch
x86
All
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [webcomptestday][platform-rel-Google][platform-rel-GoogleDocs][platform-rel-Gmail)

(Reporter)

Description

8 years ago
the scroll bar attached to the main messaging pane in Zimbra is non-functional in Firefox 3.6beta3.  it continues to work as expected in Firefox 3.5.
 
steps to reproduce:
* login to Zimbra web-based email client
* navigate to the main messaging view, where there are three panes, the top right pane containing the list of messages within your Inbox has a scroll bar on the right.
* drag the slider on the scroll bar or click on the empty space within the scroll bar to page up/down. nothing happens.
* click on the up or down arrows on the top or bottom of the scroll bar. This appears to work (i.e. moving up or down by 1) and "unlocks" the scroll bar, fixing the drag and page up/down issue.

myk melez and i were able to reproduce this in Windows 7 and Linux.
(Reporter)

Comment 1

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b5) Gecko/20091204 Firefox/3.6b5

this is still an issue with the most recent beta, and with the latest update to zimbra
(Reporter)

Comment 2

8 years ago
i'm also now seeing this in GMail with the attachment viewer.  to reproduce, email yourself a PDF document and open it within GMail.  select the "View" option next to the attachment idenifier.  the document should load within the attachment viewer. dragging and scroll bars appears to work, but clicking on the empty space or clicking on the up and down errors does not.  this also affects Google Docs.

here's a URL that can be used to reproduce loading a document within the Google Docs viewer:
http://docs.google.com/viewer?url=http%3A%2%2Flabs.google.com%2Fpapers%2Fbigtable-osdi06.pdf
Summary: certain scroll bars in content are non-functional in Zimbra → certain scroll bars in content are non-functional in Zimbra, GMail and Google Docs
(Reporter)

Updated

8 years ago
Duplicate of this bug: 529990

Comment 4

8 years ago
Found on Firefox 3.6 Web compatibility TestDay. Reproduced the scrolling issue on Firefox 3.6 release, Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Based on the comments, this is a regression.
If you need a test account there's a trail test account from Zimbra,
http://www.zimbra.com/products/hosted_demo.php
Whiteboard: [webcomptestday]

Comment 5

8 years ago
related to https://bugzilla.mozilla.org/show_bug.cgi?id=511075 ?

Comment 6

8 years ago
Same problem found on Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100123 Minefield/3.7a1pre (.NET CLR 3.5.30729) with Windows 7.

- Open a spreadsheet on Google Docs
Everything works fine (pressing the arrows, dragging the slider)

- Click on an empty space on the scrollbar
Pressing the arrows and clicking on empty spaces on the slider still works, but dragging the slider does not work anymore.

The problem exists for both vertical and horizontal scrollbars.
Whiteboard: [webcomptestday] → [webcomptestday][platform-rel-Google][platform-rel-GoogleDocs]
Whiteboard: [webcomptestday][platform-rel-Google][platform-rel-GoogleDocs] → [webcomptestday][platform-rel-Google][platform-rel-GoogleDocs][platform-rel-Gmail

Updated

2 years ago
platform-rel: --- → ?
I can no longer reproduce using the steps in comments 3 or 6.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.