Edit Account functionality is broken

VERIFIED INVALID

Status

Websites Graveyard
getpersonas.com
--
major
VERIFIED INVALID
8 years ago
5 years ago

People

(Reporter: krupa, Assigned: janitux)

Tracking

unspecified
x86
All

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
steps to reproduce:
1.Log in to your Personas account
2.Click on "Edit account"
3.Change your username to an existing value(example-"parijaatha" to "stephendonner")
4.Log out
5.Try to log in with new value
6.Try to login with your old username
7.Change your username to something new(parijaatha-->parijaatha1)
8.Try to login using the new value

expected result:
-User cant rename their username to an existing value as usernames are unique.
-After successful edit,users are not able to login with their old usernames
-After successful edit,users are able to login with their new usernames

actual result:
-User can rename their username to an existing value.
-After successful edit,users are able to login with their old usernames
-After successful edit,users are not able to login with their new usernames
Severity: critical → major
Moving, is this issue still occurring?
Assignee: rdoherty → nobody
Component: Personas → getpersonas.com
Product: Mozilla Labs → Websites
QA Contact: personas → getpersonas-com
Target Milestone: 2.0 → ---
(Reporter)

Comment 2

8 years ago
I can still reproduce this bug.
Assignee: nobody → janitux
Target Milestone: --- → 2.6
Target Milestone: 2.6 → 2.7
(Assignee)

Comment 3

8 years ago
Krupa, were you editing the display username?

Because actually, the login username can't be changed, which is fine.
You can change the display username, but you can't login with it. The display username is used to be shown at the designer's gallery title or the 'created by' on a persona detail.
(Reporter)

Comment 4

8 years ago
I see now that display name is different from login name.However,I am still unable to edit my display name.

STR:
1.Edit Account->Change User details
2.Change the display name to something else(parijaatha->parijaatha123)
3.Save changes
4.Log out and log in again.

expected behavior:
Display name is changed to the new value

actual behavior:
User changes are not saved
(Reporter)

Comment 5

8 years ago
Created attachment 437171 [details]
screenshot-04/05/10
(Assignee)

Comment 6

8 years ago
Actually, the display name is changed, but is not used on the account heading section, please check http://www.getpersonas.com/en-US/gallery/Designer/parijaatha , the display name should be on "Personas by parijaatha123"
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)
> Actually, the display name is changed, but is not used on the account heading
> section, please check
> http://www.getpersonas.com/en-US/gallery/Designer/parijaatha , the display name
> should be on "Personas by parijaatha123"

ah,I see.If you resolve the bug,I'll verify it.Thanks!
(Assignee)

Comment 8

8 years ago
actually is not a bug, closing. thanks krupa.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
Component: getpersonas.com → getpersonas.com
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.