If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JavaScript Error: "gCrashReporter is not defined" with --disable-crashreporter

VERIFIED FIXED in Firefox 3.7a1

Status

()

Firefox
General
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: dao, Assigned: dietrich)

Tracking

3.6 Branch
Firefox 3.7a1
Points:
---
Bug Flags:
blocking-firefox3.6 +

Firefox Tracking Flags

(status1.9.2 beta4-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Bug 526545 defined gCrashReporter depending on MOZ_CRASHREPORTER but uses it unconditionally.
(Assignee)

Updated

8 years ago
Assignee: nobody → dietrich
(Assignee)

Comment 1

8 years ago
Created attachment 413178 [details] [diff] [review]
fix
Attachment #413178 - Flags: review?
(Assignee)

Updated

8 years ago
Attachment #413178 - Flags: review? → review?(dao)
(Reporter)

Updated

8 years ago
Attachment #413178 - Flags: review?(dao) → review+
(Assignee)

Comment 2

8 years ago
checked in on trunk. blocks a blocker, so carrying over approval from the blockerness.

http://hg.mozilla.org/mozilla-central/rev/f43b6bc2165b
(Assignee)

Comment 3

8 years ago
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/a2fa721b5fdd
Status: NEW → RESOLVED
Last Resolved: 8 years ago
status1.9.2: --- → final-fixed
Flags: blocking-firefox3.6+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
This is not fixed in 1.9.2 nightly builds like Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b4pre) Gecko/20091120 Namoroka/3.6b4pre ID:20091120033655

Error: gCrashReporter is not defined
Source File: chrome://browser/content/browser.js
Line: 4183

You can reproduce this error when clicking the home button in the toolbar. Trunk builds don't show that and look ok on all platforms. Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20091120 Minefield/3.7a1pre ID:20091120030847

Removing final-fixed keyword.
Status: RESOLVED → VERIFIED
status1.9.2: final-fixed → ---
(Reporter)

Updated

8 years ago
Duplicate of this bug: 530266
I don't see how this could possibly have been fixed only on trunk and not branch, given that the patch landed on both and both seem to only have one reference to gCrashReporter.

Are you using your own --disable-crashreporter builds to test or something else?
Ok, looks like bug 530266 has been wrongly duped then. I'm using nightly builds and no self-build Namoroka for daily testing purposes. Same applies for Alice. So it should be independently handled. I'll move over to bug 530266 and leave this as fixed for 1.9.2.
status1.9.2: --- → final-fixed
You need to log in before you can comment on or make changes to this bug.