Error on timezone version updating

RESOLVED DUPLICATE of bug 529853

Status

Calendar
Provider: Local Storage
--
major
RESOLVED DUPLICATE of bug 529853
9 years ago
9 years ago

People

(Reporter: Sergey, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; ru; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3 ImageShackToolbar/5.2.3 (.NET CLR 3.5.30729)
Build Identifier: Lightning 1.0pre Build ID: 20091118052243

In Thunderbird nightly (Mozilla/5.0 (Windows; U; Windows NT 6.0; ru; rv:1.9.1.5) Gecko/20091117 Lightning/1.0pre Thunderbird/3.0) Lightning fails to load local calendar and show the error with following description:

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatement.reset]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///G:/Apps/ThunderbirdPortable/Data/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calStorageUpgrade.jsm :: ensureUpdatedTimezones :: line 380"  data: no]

Local calendar become disabled and unusable. I don't remember the exact build of previously installed Lightning (it was also 1.0pre), but the timezone version in old local database is 1.2009l

Reproducible: Always
Also have a look at the related Calendar blog article: http://weblogs.mozillazine.org/calendar/2009/11/getting_a_database_error_in_yo.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529853
You need to log in before you can comment on or make changes to this bug.