Release Notes link doesn't work after uploading new version of addon

VERIFIED FIXED in 5.4

Status

P2
major
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: mkaply, Assigned: wenzel)

Tracking

({regression})

unspecified
regression

Details

(Reporter)

Description

9 years ago
I submitted a new version of my addon (trackerwatcher).

After the upload, I got this page:
Version 1.0.7 Created

Your new version has been created and is currently marked as In Sandbox; Pending Review.

The new version will be available to the public as soon as an editor is able to review it. There are currently 171 other add-ons in the queue. Want to be reviewed faster? Consider becoming an editor.

View your new version in the Versions and Files page, check out your add-on's current status, or add release notes by clicking the button below (highly recommended). 

At the bottom of this page is a button for release notes. The URL is:

https://addons.mozilla.org/en-US/developers/versions/1445484813

When I click on this link, I get 

Access Denied

You are not authorized to view this page.

I have to manually go back to versions and files to navigate to a place to put in release notes.
I noticed this as well and forgot to file it.
Severity: normal → major
OS: Mac OS X → All
Priority: -- → P2
Hardware: x86 → All
Target Milestone: --- → 5.4
Keywords: regression
(Assignee)

Comment 2

9 years ago
Probably regressed when implementing hosted add-ons. Taking.
Assignee: nobody → fwenzel
Duplicate of this bug: 529740
(Assignee)

Comment 4

9 years ago
Fixed in r56402!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: push-needed
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 529941
Verified, FIXED.
Status: RESOLVED → VERIFIED

Comment 7

9 years ago
Developer Hub Manage AFOM Version 4.4 Release Notes

Says, after uploading a new version I need special permission to place the Release Notes. It forced me to add the new update to AFOM Plus 4.3 to 4.4 without Release Note and followed by submitting then followed by editing the blank Release Note to the newly updated version.

Regards,
richard tharp
or
IDEVFH

Comment 8

9 years ago
When is AMO corrected?
It encountered this bug today.
I believe this is scheduled to be pushed on 12/8. However, it might be a good idea to push this early, considering that a few hundred updates will go through before then.

Does this bug happen for every single update?
> Does this bug happen for every single update?

As far as I can say, yes.
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.