Port bug Bug 407875 to Fennec so unprivileged users are notified / can check for updates

RESOLVED WONTFIX

Status

Fennec Graveyard
General
RESOLVED WONTFIX
8 years ago
a year ago

People

(Reporter: rstrong, Unassigned)

Tracking

Details

I'm hoping to land bug 407875 on the 1.9.2 branch. The patches in bug 407875 should be enough to go on and don't hesitate to ping me on irc if there are any questions
Depends on: 407875
Flags: wanted-fennec1.0?
Note: Bug 529942 will move (hopefully soon) the two new attributes from nsIApplicationUpdateService2 to nsIApplicationUpdateService on trunk
As far as I know we have no plans to use the app update service on Maemo. We should probably look into disabling it completely (ideally by avoiding loading the the component entirely rather than just using the pref).

I have no idea what the plans are for Windows Mobile.
Building with ac_add_options --disable-updater will not build the binary or the component as of 1.9.2 so you should be able to do this today.
(In reply to comment #2)
> I have no idea what the plans are for Windows Mobile.

We'll be using the update service for Windows Mobile
Gavin, just checked the contents of fennec-1.0b6pre.en-US.linux-gnueabi-arm and it does build with updater enabled. You'll get a small TS gain by disabling the updater per comment #3.
(In reply to comment #5)
> Gavin, just checked the contents of fennec-1.0b6pre.en-US.linux-gnueabi-arm and
> it does build with updater enabled. You'll get a small TS gain by disabling the
> updater per comment #3.

filed bug 530393
If you prefer, we can also remove pref("app.update.showInstalledUI", false); from mobile.js (I noticed that mobile.js doesn't include prefs if the default is correct) since I flipped the default in the update service.
Flags: wanted-fennec1.0?
Not used by fennec anymore
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.