javascript errors and data munging, and forms

VERIFIED DUPLICATE of bug 22163

Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 22163
17 years ago
13 years ago

People

(Reporter: Hallvard B Furuseth, Assigned: asa)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.7 sun4u)
BuildID:    2000091521

I don't know if these errors are related, but they
came at the same time.  I'll investigate in detail
and/or post separate bugs if someone tells me what
to check...
- I get some persistent JavaScript errors, the
  output below comes from an attempt to file this bug.
- A GIF attachment I posted to bugzilla, differs from the
  original.  Don't know if that's a mozilla data posting
  bug, or a bugzilla bug, or what:
   http://bugzilla.mozilla.org/showattachment.cgi?attach_id=14879
vs http://www.uio.no/~hbf/m.gif
- Also, two other problems have come back with forms:
  I can't paste into a form (at least not bugzilla-helper).
  That one may have been around for a while; don't remember.
  Also, when I type anything into bugzilla-helper, Mozilla
  keeps jumping down to the bottom of the page so I have
  to scroll up to continue typing.  I think that bug comes
  and goes.
  (I'm posting this with netscape.)

Anyway, here is the mozilla session:

$ mozilla http://www.mozilla.org/
CHROME ALPHA ABUSE
        using an 8-bit alpha channel to represent binary alpha
        chrome://communicator/skin/bookmarks/bookmark-item.png
        num000=43 num255=139 sum=182 w*h=182
Setting content window
*** Pulling out the charset
in SetSecurityButton
Document http://www.mozilla.org/ loaded successfully
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPref.GetBoolPref]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: URLBarLeftClickHandler :: line 2128" 
data: no]

JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPref.GetBoolPref]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: URLBarBlurHandler :: line 2137" 
data: no]

Document http://bugzilla.mozilla.org/ loaded successfully
dragstart
didnt get here
****** returning null 3
Error loading URL http://www.mozilla.org/quality/help/bug-form.html: 804b0002 
Document http://www.mozilla.org/quality/help/bugzilla-helper.html loaded
successfully
JavaScript error: 
 line 5: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPref.GetBoolPref]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: URLBarBlurHandler :: line 2137" 
data: no]

Setting content window
*** Pulling out the charset
in SetSecurityButton
Document
http://bugzilla.mozilla.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=UNCONFIRMED&field0-0-0=short_desc&type0-0-0=substring&value0-0-0=(NS_ERROR_UNEXPECTED)&field1-0-0=short_desc&type1-0-0=substring&value1-0-0=[nsIPref.GetBoolPref]&cmdtype=doit
loaded successfully
dragstart
didnt get here
****** returning null 3
dragstart
didnt get here
****** returning null 3
dragstart
didnt get here
****** returning null 3
dragstart
didnt get here
****** returning null 3
dragstart
didnt get here
****** returning null 3
PREF_Cleanup()
$ 

Reproducible: Sometimes
Steps to Reproduce:
1. mozilla http://www.mozilla.org/
2. Click on the URL bar (where you'd type another URL),
   that gives one of the exceptions.
3. Click on the Bugzilla link, that gives another
   exception.
4. Try to type and paste.  More exceptions & problems.

Comment 1

17 years ago
the GetBoolPref error output is due to a missing checkin for bug 22163
The bug was reopened.
Marking dup.


*** This bug has been marked as a duplicate of 22163 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.