Right mouse button menu don't work on images

RESOLVED WORKSFORME

Status

()

Firefox
Menus
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Kenneth Langdalen, Unassigned)

Tracking

3.6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b3) Gecko/20091118 Mandriva Linux/1.9.2-0.b3.1mdv2010.1 (2010.1) NeX/0.2.5 Firefox/3.6b3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b3) Gecko/20091118 Mandriva Linux/1.9.2-0.b3.1mdv2010.1 (2010.1) NeX/0.2.5 Firefox/3.6b3

the right mouse button menu don't work on images. The menu appears, but the options have no effect.

Reproducible: Always

Steps to Reproduce:
1. Right click on the image link
2. Click on any of the options
Actual Results:  
Nothing

Expected Results:  
Executed the chosen option
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Updated

9 years ago
Component: General → Menus
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b4pre) Gecko/20091116 Namoroka/3.6b4pre

The google image shows a context menu here and the options I tried work fine for me. So no problem here on Windows.
QA Contact: general → menus
Kenneth, have you tried running Firefox in Safe Mode (http://support.mozilla.com/kb/Safe+Mode) yet? It will disable all of your extensions. Looks like that one is causing this problems. Btw. do you see any error in the error console (you can find it under the tools menu) when clicking a context menu entry?

Comment 3

9 years ago
I can confirm that (I don't run in safe mode but my profile is new and I don't have any extension installed...
I also sometimes get a context menu with ALL options possible ( from spell checking to video options ...) instead of the normal short menu... but I don't know yet how I can reproduce that...



        Name

        Firefox



        Version

        3.6b4

Comment 4

9 years ago
I found out some other stuff don't know if this helps: if the image is a link I can't use the "open in new tab" entry, too.

There is nothing in the error console....

Comment 5

9 years ago
I installed add block plus and the strange thing is, that the Block Image menu item from addblockplus works... the other items still don't work...

Comment 6

9 years ago
somehow this got fixed when I installed the fix for bug #531053 (don't know how they are related but it worked for me ;) )
So it's perhaps only a duplicate...

Comment 7

9 years ago
I have the same problem. Linux, 64bit, Firefox 3.5.6

I found that the context menu on images shows ALL possible entries (including all the stuff not related to images) until I open a context menu on a non-image object. Then a reduced context menu appears for images, which does not contain the "save image as" entry and other entries like "properties" do nothing at all (clicking them has no effect other than closing the menu).

Removing ~/.mozilla has no effect but I could (temporarily) remedy the problem by wiping /tmp completely clean, so it's apparently something Firefox creates there. Unfortunately the issue reappeared after a couple of firefox restarts, again wiping /tmp helped.

The issue first appeared after the update to 3.5.6, 3.5.5 was fine. I hope this helps finding the cause.

Comment 8

9 years ago
Wiping /tmp seems to help only if I have no saved open tabs from the previous session, otherwise it persists even then. When the issue is "active" I have this on the error console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch2.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://browser/content/browser.js :: BATH__updateCommandState :: line 8254"  data: no]

and whenever I open a faulty image context menu I get this:

RefControl: handleEvent: TypeError: gContextMenu is null

Unless "RefControl" is an internal name I will keep the extension of the same name now disabled and see how it goes.

Comment 9

9 years ago
Keeping RefControl disabled does not prevent the bug from reappearing.

I noticed when the issue is present, there is no short info about current downloads in the status bar. These two quirks always appear together.

Comment 10

9 years ago
I found out this happens only if I save open tabs when closing Firefox, if I close all additional tabs when exiting then everything is back to normal (until I save tabs again). Possibly an issue with the session restore?

Comment 11

9 years ago
Works for me based on comment 6 from reporter. 

Caper7 please file a new bug after verifying that Firefox's safe mode or creating a second profile does not help http://support.mozilla.com/en-US/kb/Basic+troubleshooting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.