Closed Bug 529780 Opened 10 years ago Closed 10 years ago

can't copy message to a virtual folder

Categories

(Thunderbird :: Folder and Message Lists, defect, major)

x86
Windows Vista
defect
Not set
major

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: emoore, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091117 Thunderbird/3.0

I'm using build 2 of Thunderbird 3.0RC1. I created a virtual folder called glasses in an IMAP account that tests whether the subject contains glasses. 

I copied one of the messages in the virtual folder to the inbox in local folders. I also sent a new message to a POP account whose subject is glasses. I can't copy either message to the folder using the message menu or the context menu because the folder doesn't show up in the folder list. I can't drag and drop either message to that folder - I get a circle with a slash through it when I drag the mouse over the folder. I tested with the virtual folders configured both as online and normal folders.

I have the same problem with a 20091113 nightly build and beta 4. I'm using the same profile with all three versions. I created a new (different) virtual folder using beta 4 and it has the same type of problem. This is confusing since it used to work!

I have the same problem using a virtual folder that is the only child of the local folders inbox. Whats interesting though is that in this case the folder listing shows a black arrow to the right of the inbox (indicating it knows there are child folders) and a green checkmark next to "copy here". I don't get the black arrow if I copy it to the drafts or templates folder in local folders.



Reproducible: Always
Blocks: qa-tb3.0rc1
(In reply to comment #0)
> I copied one of the messages in the virtual folder to the inbox in local
> folders. I also sent a new message to a POP account whose subject is glasses. I
> can't copy either message to the folder using the message menu or the context
> menu because the folder doesn't show up in the folder list. I can't drag and
> drop either message to that folder - I get a circle with a slash through it
> when I drag the mouse over the folder. I tested with the virtual folders
> configured both as online and normal folders.

Let me check: You are tried to copy messages to a virtual folder (aka Saved Search folder)?

If so that isn't allowed as these are special search folders and only show search results, you can't add other emails into those folders.
So shall copy to a birtual folder be permited and move not ?
See Also: → 528690
(In reply to comment #2)
> So shall copy to a birtual folder be permited and move not ?

A move or a copy to a virtual folder is not permitted - the virtual folder doesn't know what to do with them.
It is deliberate as observed in comment #3: close as INVALID.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.