Views borked using wcap: dayHeaderBox.mItemBoxes is null

RESOLVED FIXED in 1.0b1

Status

Calendar
Provider: WCAP
--
critical
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: dbo, Assigned: dbo)

Tracking

({regression})

Trunk
1.0b1
regression
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [not needed beta][no l10n impact])

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Adding a WCAP account works and correctly shows the newly added calendar, but on restart of the application, the views are trashed. I suspect the following console error is related:

Error: [Exception... "'[JavaScript Error: "dayHeaderBox.mItemBoxes is null" {file: "chrome://calendar/content/calendar-multiday-view.xml" line: 2891}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calUtils.jsm -> file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/calendar-js/calUtils.js :: notifyFunc :: line 1225"  data: yes] STACK: 1: [file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calUtils.jsm -> file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/calendar-js/calUtils.js:1228] notifyFunc
2: [file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calUtils.jsm -> file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/calendar-js/calUtils.js:1231] calListenerBag_notify
3: [file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calProviderUtils.jsm:439] calObserverBag_notify
4: [file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/components/calCompositeCalendar.js:209] cCC_addCalendar
5: [file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/components/calCompositeCalendar.js:184] anonymous
6: [file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/components/calCompositeCalendar.js:187] anonymous
7: [null:0] null
8: [chrome://calendar/content/calUtils.js:1840] getCompositeCalendar
9: [chrome://calendar/content/widgets/minimonth.xml:1024] getItems
10: [chrome://calendar/content/widgets/minimonth.xml:916] showMonth

Source File: file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calUtils.jsm -> file:///Users/dbo/moz/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/calendar-js/calUtils.js
Line: 1228
(Assignee)

Updated

9 years ago
Flags: blocking-calendar1.0?

Comment 1

9 years ago
Hello,

I have something very similar on LINUX:

I have just:

wget ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-comm-1.9.1/linux-xpi/lightning.xpi

wget http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1-l10n/thunderbird-3.0.1pre.fr.linux-i686.tar.bz2

and I'm running:
Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.5) Gecko/20091119 Lightning/1.0pre Shredder/3.0.1pre

I have removed all my TB preferences.

Adding WCAP calendar is ok and after restarting TB, WCAP cal's aren't showed and I have this error message:

Erreur : [Exception... "'[JavaScript Error: "this.treebox is null" {file: "chrome://calendar/content/widgets/calendar-list-tree.xml" line: 562}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1225"  data: yes] STACK: 1: [file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1228] notifyFunc
2: [file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1231] calListenerBag_notify
3: [file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calProviderUtils.jsm:439] calObserverBag_notify
4: [file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:209] cCC_addCalendar
5: [file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:184] anonymous
6: [file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:187] anonymous
7: [null:0] null
8: [chrome://calendar/content/calUtils.js:1840] getCompositeCalendar
9: [chrome://calendar/content/calendar-task-tree.xml:154] 

Fichier Source : file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/bouchero/.thunderbird/1ppvuv7n.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Ligne : 1228

Comment 2

9 years ago
I've been seeing this for a few days now. The network cal is missing but the cal appts show in a grayed out fashion. I think 470055 is reporting something very similar.

First error I get in the console is 


Error: [Exception... "'[JavaScript Error: "dayHeaderBox.mItemBoxes is null" {file: "chrome://calendar/content/calendar-multiday-view.xml" line: 2891}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1225"  data: yes] STACK: 1: [file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1228] notifyFunc
2: [file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1231] calListenerBag_notify
3: [file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calProviderUtils.jsm:439] calObserverBag_notify
4: [file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:209] cCC_addCalendar
5: [file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:184] anonymous
6: [file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:187] anonymous
7: [null:0] null
8: [chrome://calendar/content/calUtils.js:1840] getCompositeCalendar
9: [chrome://calendar/content/calendar-task-tree.xml:154] 

Source File: file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/<myaccount>/AppData/Roaming/Thunderbird/Profiles/ks1k69qf.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1228
Line: 1228
 
Then I get the "this.treebox is null" then the "dayHeaderBox.mItems is null" and then the two keep repeating.

Comment 3

9 years ago
I'm seeing this same behaviour on the rc1 builds on OpenSolaris.
(Assignee)

Comment 4

9 years ago
This seems to be related to using a master password; if I don't use one the problem is gone. Since WCAP uses the same calAuthUtils.jsm code like any other provider the problem should be reproducable by other providers, too, e.g. gdata.
Could anybody confirm this?
OS: Mac OS X → All
Hardware: x86 → All

Comment 5

9 years ago
You are right, removing the master password suddenly brings back all my calenders into the view!

Comment 6

9 years ago
(In reply to comment #4)
> This seems to be related to using a master password; if I don't use one the
> problem is gone. Since WCAP uses the same calAuthUtils.jsm code like any other
> provider the problem should be reproducable by other providers, too, e.g.
> gdata.
> Could anybody confirm this?

Also confirmed: after removing the master password everything works like a charm !!!

PL
(Assignee)

Comment 7

9 years ago
Does anybody use gdata with a master password?
(Assignee)

Comment 8

9 years ago
I've tested against gdata and it works, however why since wcap uses the same calAuthUtils routines. Maybe it relates to timing-dependent startup (e.g. see the broken XUL the stack indicates).

I strongly vote to block 1.0 on this since using a master password is quite common.
We should try to fix this for the next beta. I'll also take a fix for b1 if we have an rc2 and a fix. The problem for me is that I don't have access to a WCAP server and it looks complicated to set up one (lots of downloads, needs whole java communication suite).
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Whiteboard: [not needed beta][no l10n impact]
(Assignee)

Comment 10

9 years ago
Created attachment 416754 [details] [diff] [review]
remove master pw hack

This regression seems to have been caused by change
<http://hg.mozilla.org/comm-central/rev/31247e265853>

I think we should simply remove the hack (calling the password manager at an early stage) since it hasn't worked any longer for quite some time. We need a more thorough solution (i.e. fix for bug 349641).
Attachment #416754 - Flags: review?(philipp)
(Assignee)

Updated

9 years ago
Assignee: nobody → dbo.moz
Status: NEW → ASSIGNED
Keywords: regression
Comment on attachment 416754 [details] [diff] [review]
remove master pw hack

Glad you found the Problem! Taking this for rc1.
Attachment #416754 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/4a742757bb31>
and comm191: b23c67942126 (default) / 65fcedf15e56 (1.0b1 relbranch)

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.