Add Firefox 3.0.11 to AMO valid versions list

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Administration
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: Jason Sonnenschein, Assigned: fligtar)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.251.0 Safari/532.5
Build Identifier: 

In the AMO developer pages, the extension developer can set firefox version compatibility for their extensions.  Firefox version 3.0.11 is not an option there.  I maintain an extension that was affected by a bug in Firefox versions 3.0.5-3.0.10 and would like to set minimum compatibility to 3.0.11

Reproducible: Always

Steps to Reproduce:
1. Go to Addons.mozilla.org website
2. Log in and use developer tools
3. Try to change version compatibility for a maintained extension in "files and versions"
Actual Results:  
3.0.11 is not in the list, though 3.0.9 and below are

Expected Results:  
3.0.11 will be in the list

Comment 1

9 years ago
Is there a bug number for the issue that was fixed? Also, is there a corresponding 3.5.x version that should be added, or did this bug only affect 3.0.x?
Summary: Selecting Firefox version 3.0.11 for extension compatibility on AMO → Add Firefox 3.0.11 to AMO valid versions list
(Reporter)

Comment 2

9 years ago
The issue was https://bugzilla.mozilla.org/show_bug.cgi?id=406646

The bug only affected 3.0.x

Comment 3

9 years ago
Seems like a valid request to me. 3.0.9 was also added at the request of an extension developer who wanted it (bug 491169).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

9 years ago
There's a big difference between the circumstances of that bug and this one: when 3.0.9 was added, Firefox 3.0.x was still the current release. Now, no users should be using a version that old with public security vulnerabilities. Will think about this on Monday.

Comment 5

9 years ago
True, but an extension's version range isn't really related to that. We don't exactly block out-of-date users from installing or updating extensions and no one should be using 3.0 but that can still be set as a minimum. A version of 3.0.15 could be warranted instead, though that's not actually the minimum supported version so that would feel odd to me.
(Reporter)

Comment 6

9 years ago
Although I agree no one "should" be using a version that old, when I look at graphs for my extension, some folks still are using firefox older than 3.0.11
(Reporter)

Comment 7

9 years ago
I'm curious... What are the arguments against adding it?  Does it do some harm somewhere?
(Assignee)

Comment 8

9 years ago
Added 3.0.11.

(In reply to comment #7)
> I'm curious... What are the arguments against adding it?  Does it do some harm
> somewhere?

It's just another option to confuse people. Surprisingly, add-on developers often don't understand how the compatibility ranges work.
Assignee: nobody → fligtar
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified FIXED on https://addons.mozilla.org/en-US/firefox/pages/appversions.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

9 years ago
Thanks guys
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.