crash [::JS_Assert(const char *s, const char *file, JSIntn ln) ]

RESOLVED DUPLICATE of bug 529837

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 529837
9 years ago
9 years ago

People

(Reporter: surkov, Unassigned)

Tracking

({access, crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
stack trace. The crash happens in a11y mochitest - tree/test_list_invalidate.html

>	mozjs.dll!JS_Assert(const char * s=0x006833a4, const char * file=0x0068337c, int ln=0x000000ca)  Line 67	C++
 	mozjs.dll!js_FillPropertyCache(JSContext * cx=0x04e85b60, JSObject * obj=0x07e5e9a0, unsigned int scopeIndex=0x00000000, unsigned int protoIndex=0x00000000, JSObject * pobj=0x07e5e9a0, JSScopeProperty * sprop=0x06d939a0, int adding=0x00000000)  Line 202 + 0x90 bytes	C++
 	mozjs.dll!js_GetPropertyHelper(JSContext * cx=0x04e85b60, JSObject * obj=0x07e5e9a0, int id=0x07e46754, unsigned int getHow=0x00000003, int * vp=0x0012f22c)  Line 4484 + 0x1d bytes	C++
 	mozjs.dll!js_GetMethod(JSContext * cx=0x04e85b60, JSObject * obj=0x07e5e9a0, int id=0x07e46754, unsigned int getHow=0x00000003, int * vp=0x0012f22c)  Line 4507 + 0x19 bytes	C++
 	mozjs.dll!js_Interpret(JSContext * cx=0x04e85b60)  Line 1653 + 0x28 bytes	C++
 	mozjs.dll!js_Invoke(JSContext * cx=0x04e85b60, unsigned int argc=0x00000000, int * vp=0x04d7bbc8, unsigned int flags=0x00000000)  Line 1383 + 0x9 bytes	C++
 	xpc3250.dll!nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS * wrapper=0x06608488, unsigned short methodIndex=0x0003, const XPTMethodDescriptor * info=0x010819d8, nsXPTCMiniVariant * nativeParams=0x0012f6f8)  Line 1696 + 0x1b bytes	C++
 	xpc3250.dll!nsXPCWrappedJS::CallMethod(unsigned short methodIndex=0x0003, const XPTMethodDescriptor * info=0x010819d8, nsXPTCMiniVariant * params=0x0012f6f8)  Line 571	C++
 	xpcom_core.dll!PrepareAndDispatch(nsXPTCStubBase * self=0x0455fff0, unsigned int methodIndex=0x00000003, unsigned int * args=0x0012f7b8, unsigned int * stackBytesToPop=0x0012f7a8)  Line 114 + 0x21 bytes	C++
 	xpcom_core.dll!SharedStub()  Line 142	C++
 	xpcom_core.dll!nsThread::ProcessNextEvent(int mayWait=0x00000001, int * result=0x0012f800)  Line 527 + 0x19 bytes	C++
 	xpcom_core.dll!NS_ProcessNextEvent_P(nsIThread * thread=0x00cbb120, int mayWait=0x00000001)  Line 250 + 0x16 bytes	C++
 	gkwidget.dll!nsBaseAppShell::Run()  Line 170 + 0xc bytes	C++
 	toolkitcomps.dll!nsAppStartup::Run()  Line 182 + 0x1c bytes	C++
 	xul.dll!XRE_main(int argc=0x00000005, char * * argv=0x00ce0ed0, const nsXREAppData * aAppData=0x00ce1c60)  Line 3491 + 0x25 bytes	C++
 	firefox.exe!NS_internal_main(int argc=0x00000005, char * * argv=0x00ce0ed0)  Line 158 + 0x12 bytes	C++
 	firefox.exe!wmain(int argc=0x00000005, wchar_t * * argv=0x00cbaaa8)  Line 120 + 0xd bytes	C++
 	firefox.exe!__tmainCRTStartup()  Line 583 + 0x19 bytes	C
 	firefox.exe!wmainCRTStartup()  Line 403	C
 	kernel32.dll!7c817077() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]	
 	mozjs.dll!TraceRecorder::record_JSOP_OBJTOP()  Line 10295 + 0xa bytes	C++
(Reporter)

Comment 1

9 years ago
it sounds the regression range is between ddd50257e653  and af81717d2be9  (http://hg.mozilla.org/mozilla-central/shortlog/35011), at least tinderboxes a11y mochitests started to fail regular.
Assignee: nobody → general
Component: XPConnect → JavaScript Engine
QA Contact: xpconnect → general

Updated

9 years ago
Severity: normal → critical
Similar to bug 529837 (dupe?)
(Reporter)

Comment 3

9 years ago
Yes, sounds so. Similar stack trace, the same mochitest crashes.
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529837
You need to log in before you can comment on or make changes to this bug.