Localhost is not accesabe when i'm plug out from LAN

RESOLVED DUPLICATE of bug 339814

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 339814
9 years ago
8 years ago

People

(Reporter: lubospit, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sk; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sk; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

When i don't have connected lan cable or connected any WLAN, i can't acces to http://localhost/ or http://127.0.0.1/. I develop web sites and when i travel, i'm not connected to any network, then my TOMCAT server's page is not accesible from firefox, but it is accesable from opera, ie, chrome.

Reproducible: Always

Steps to Reproduce:
1.unplug lan cable and disconnect WIFI LAN
2.run tomcat server (maybe another web server)
3.clear FF cache
4. try acces to http://localhost/
Actual Results:  
FF display page "offline mode"

Expected Results:  
display page of app server

Comment 1

9 years ago
Make sure you uncheck "work offline" and try again. also, what happens when you go to the url: http://127.0.0.1/ ?

I also develop web apps with a local server and have never experienced this. Just tested with Firefox trunk nightly.
(Reporter)

Comment 2

9 years ago
I'm sorry i had it checked. Now it is working. With  http://127.0.0.1/ also.

Thanks for fix my problem. But i'dont know who or what check that checkbox. 

I maked this bug as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 3

8 years ago
This is the same as bug 339814, which has not been marked INVALID.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 339814
You need to log in before you can comment on or make changes to this bug.