Support css property text-shadow for elements within <svg>

RESOLVED DUPLICATE of bug 889235

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 889235
9 years ago
6 years ago

People

(Reporter: s3lance, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/532.4 (KHTML, like Gecko) Version/4.1 Safari/532.4
Build Identifier: 

text shadows doesn't show up if I apply text-shadow on the <svg> node, and any nodes within

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 413386 [details]
Test case for the problem

Text shadow displayed on any text element outside <svg>
Text shadow not displayed if applied on <svg> or any element within <svg>
The CSS that SVG should support is defined in the specification here: http://www.w3.org/TR/SVG/propidx.html

If you want text-shadow added to a subsequent version of the SVG specification you need to take that up with the w3c SVG working group. The good news for you is that the SVG WG are considering what to have in SVG 2.0 right now.

In the meantime there are SVG ways to do shadows e.g. http://www.xml.com/pub/a/2004/06/02/svgtype.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Resolution: INVALID → DUPLICATE
Duplicate of bug: 889235
You need to log in before you can comment on or make changes to this bug.