[HTML5] Crash when going to [@ nsHtml5TreeOperation::Perform]

RESOLVED DUPLICATE of bug 525229

Status

()

--
critical
RESOLVED DUPLICATE of bug 525229
9 years ago
7 years ago

People

(Reporter: streetwolf, Unassigned)

Tracking

({crash, html5})

Trunk
x86_64
Windows 7
crash, html5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091119 Minefield/3.7a1pre Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091119 Minefield/3.7a1pre - Build ID: 20091119050202

Crashed and exited to the desktop.

Reproducible: Always

Steps to Reproduce:
1. html5.enable = True
2. Go to URL given
3. 
Actual Results:  
Crash.

Expected Results:  
Site should appear normally.

html5.enable = False  produces NO crash

Firefox 3.7a1pre Crash Report [@nsHtml5TreeOperation::Perform(nsHtml5TreeOpExecutor*) ]
Search Mozilla Support for Help
ID: e270840f-91b0-4d4a-85ed-c94552091119
Signature: nsHtml5TreeOperation::Perform(nsHtml5TreeOpExecutor*)
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
URL takes you to a login screen.
(Reporter)

Updated

9 years ago
Component: DOM: Core & HTML → HTML: Parser
(Reporter)

Updated

9 years ago
Keywords: crash, html5

Comment 2

9 years ago
bp-e270840f-91b0-4d4a-85ed-c94552091119
QA Contact: general → parser
Summary: Crash when going to http://www.optimum.net/WiFi/Authentication → Crash when going to [@ nsHtml5TreeOperation::Perform]

Comment 3

9 years ago
Signature	nsHtml5TreeOperation::Perform(nsHtml5TreeOpExecutor*)
UUID	e270840f-91b0-4d4a-85ed-c94552091119
Time 	2009-11-19 15:33:52.53943
Uptime	661
Last Crash	674 seconds before submission
Product	Firefox
Version	3.7a1pre
Build ID	20091119050202
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 26 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x1
User Comments	
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 		@0x1 	
1 	xul.dll 	nsHtml5TreeOperation::Perform 	parser/html/nsHtml5TreeOperation.cpp:104
2 	xul.dll 	nsHtml5TreeOpExecutor::Flush 	parser/html/nsHtml5TreeOpExecutor.cpp:312
3 	xul.dll 	nsHtml5ExecutorFlusher::Run 	parser/html/nsHtml5StreamParser.cpp:110
4 	xul.dll 	nsThread::ProcessNextEvent
The crash I see when I click on the URL is:

[@nsHtml5PendingNotification::nsHtml5PendingNotification(nsIContent*) ]
http://crash-stats.mozilla.com/report/index/bp-87a60977-0999-4c98-a4b7-05b6b2091119
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Crash when going to [@ nsHtml5TreeOperation::Perform] → [HTML5] Crash when going to [@ nsHtml5TreeOperation::Perform]
Potential duplicate of bug 525229.
Not crashing with the patch for bug 525229.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 525229
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsHtml5TreeOperation::Perform]
You need to log in before you can comment on or make changes to this bug.