Impossible to see the actual fonts and sizes of messages when composing

RESOLVED DUPLICATE of bug 98763

Status

RESOLVED DUPLICATE of bug 98763
9 years ago
9 years ago

People

(Reporter: lchicago, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.23

VERY IMPORTANT - I would like to set up the display font to be exactly the same as the sent message font. Is there a way I can NOT set up a display font, that is, I can have the display font to be the font that will be used to send the messages????

This is a real problem for me as I keep sending messages that look perfect to me (and look perfect in my sent folder) but have all different font sizes as I am not able to see the font they will be sent because my display font is a DEFINED Font that prevents me to see the REAL font that will be shown when the message is sent. This must have an easy solution and I do not know why Thunderbird has not solved this problem in the last 12 years!! if I am composing an e-mail and copy parts into it from different documents, I see the composition using my display font on the screen, but they are sent out in the font from my other documents from where I copied it. It makes the message look terrible for the recipient but perfect to me when I am composing. YOU MUST CHANGE THIS URGENTLY.

Any solutions???

I had already read the available links many times. It says that the display when composing is not what will be sent but does not say how do you see what will be sent? This question must be send to the developing group. How do you do that?

    * Reply with quote

Today, 3:50 pm

Post Posted Today, 3:50 pm
Email is not like hard copy mail. Even if you see what you are going to send, it does NOT mean that you are seeing what the recipient will see. You have no control over the settings they have chosen on their system. They could receive all messages in plain text, eliminating the font issue. They could have chosen a black background, making your choice of black text problematic. They may have chosen an increased display font size so your choice of a large font in the outgoing message produces excessively large characters.

When copying and pasting from another program the better choice is to paste without formatting and then format within Thunderbird. That ensures that there are no potential problems with Thunderbird's interpretation of the HTML from the other program. (MSWord, for instance, produces extremely bad HTML code.)
Dan Raisch Vista Home Premium 64, FF 3.5.5, TB 2.0.0.23
Guest
    Guest
     

    * Reply with quote

Today, 4:02 pm

Post Posted Today, 4:02 pm
Thanks for your reply. Copying and pasting without formatting is what I do, but sometimes I forget and I can get very very embarrassed by what I sent out. It looks so perfect when I am composing it that is hard to believe that it was such a mess of fonts and font sizes. There should be an option for "no change in the display", that is, display what is put in the message without any change.

I am sure that the recipient could change the display and I would hope they all did because of this problem with Thunderbird, but that is not the case. I myself allow the messages to show as written and I see my messy messages when people reply to me. They look terrible although they looked perfect when I composed them and in my sent file. This is a real problem that should have been fixed by Thunderbird Development group a long time a go. Can you send a request to review this problem? It is very embarrassing and not my fault as I cannot see what I am sending. A huge problem of the software.
Post Posted 18 minutes ago
But it is too late to review the message in the sent folder and I had cases in which they looked ok in my sent folder (the sent folder was using my Display settings too as it is displaying the message) but in reality, they were displayed in another computer that allowed "display as is" without changes, all messed up. It is a real problem for Thunderbird. Can you send my comments to the development team.

    

Reproducible: Always

Steps to Reproduce:
1. copy any large font text with a variety of fonts into your composer 
2. send the e-mail - it looks right because it is using the display font for you and you cannot see the real font that will show in the recipient computer
3.ask someone to reply to you so you can see the mess you sent out
4, there is no way you can review the message to make sure it is right before sending out on Thunderbird!!
Component: General → Mail Window Front End
QA Contact: general → front-end
Whiteboard: dupme?
Version: unspecified → 2.0
Ichicago your issue it seems a dupe of bug #308437. If you agree, please, close yourself this bug as Resolved Duplicate.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme?
Duplicate of bug: 98763
You need to log in before you can comment on or make changes to this bug.