colorpicker in prefs only give js error

VERIFIED WORKSFORME

Status

SeaMonkey
Preferences
P2
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: R.K.Aa., Assigned: Chris McAfee)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][PDTP2])

(Reporter)

Description

18 years ago
2000091606 linux

open prefserences/appearance/color
try to set a color for any of the options:
-Nothing happens. Console tells:


JavaScript error:
 line 1: this.mColorBox has no properties
(Reporter)

Comment 1

18 years ago
error in summary
Summary: colorpicker in only give js error → colorpicker in prefs only give js error
(Reporter)

Comment 2

18 years ago
forgot the next line:

JavaScript error:
 line 1: this.mPicker has no properties
(Reporter)

Comment 3

18 years ago
Similarly: clicking prefs/composer/new page settings:

Error to console:

JavaScript error:
chrome://communicator/content/pref/prefutilities.js line 1: redeclaration of
const nsIFilePicker

Clicking buttons there do *not* dropdown a box, as one might expect it to do
judging by the arrows on the buttons.

Comment 4

18 years ago
Not a Profile problem, reassigning owner/QA contact
Assignee: ben → matt
Component: Profile Manager FrontEnd → Preferences
QA Contact: gbush → sairuh
->mcafee for color prefs. but since the editor color picker (in New Page
Settings panel) is also broken, am gonna cc cmanske and beppe.

definite recent regression here; nominate for beta3.
Keywords: nsbeta3, regression

Comment 6

18 years ago
I'm giving this to mcafee since
he knows the color picker better then me
Assignee: matt → mcafee
(Reporter)

Comment 7

18 years ago
2000091821:
Clicking prefs/composer/new page settings still produce the js error
(chrome://communicator/content/pref/prefutilities.js line 1: redeclaration of
const nsIFilePicker) but when checking radiobutton for user-colors, colorpicker
appears and the buttons reflect new picked color.

(Trying to use prefs/appearance/colors still doesn't work; line 1: this.ColorBox
has no properties)
what i saw in New Page Settings is not related to this one --pilot error
resulted in finding another bug, bug 53275.

Comment 9

18 years ago
nsbeta3+, P2
Priority: P3 → P2
Whiteboard: [nsbeta3+]

Comment 10

18 years ago
PDT agrees P2, and we really really don't want to ship with this bug.
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP2]
(Reporter)

Comment 11

18 years ago
Well well..  this bug keeps fading away all on it's lonesome:

linux 2000092008:

in pref/appearance/colors things now work OK again! No js errors - colors are
set - business as usual.


in prefs/composer/new page the js error is still sent to console, but
appearantly has no other effect: colors can be modified.

Someone else must be working on this - just haven't found the bug #.
holy poop, you're right, rkaa! the color picker in the Colors panel is now
appearing, magically wfm. but the color prefs are broken anyhow due to bug
22963.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
vrfy wfm.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.