Crashes [@dlopen ] on all branches, usually at startup, possibly caused by the WebEx plug-in

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
9 years ago
2 years ago

People

(Reporter: alqahira, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webex], crash signature)

With Camino 2, we're seeing a number of startup crashes in dlopen related to plug-in scanning code.  The comments aren't very helpful.

http://crash-stats.mozilla.com/report/list?product=Camino&version=Camino%3A2.0&query_search=signature&query_type=exact&query=dlopen&date=&range_value=1&range_unit=weeks&do_query=1&signature=dlopen

However, I expanded the search and am seeing the crash in Fx 3.6bx, 3.5.x, and 3.0.x results as well, and a couple of the comments there mentioned that the user had just installed the WebEx plugin or was trying to access WebEx.

http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=dlopen&date=&range_value=4&range_unit=weeks&do_query=1&signature=dlopen

Some of the Modules lists show WebEx loaded, some don't (even some where the reporter seems to think WebEx is related), so it may not be the cause, or there may be multiple plugins causing this, or....

Comment 1

9 years ago
This problem occured on my system just after I upgraded from Firefox 3.5 to 3.6.
It seems to crash when trying to reopening the 4 different tabs which where open just before the upgrade. I don't remember to have installed the webex plugin on my system.Other plug-in should be involved. On other sessions on my computer, no problem at all.
It's possible dbaron's "interesting modules" stuff could help here, but I think when I talked to smorgan about this crash originally, he thought it was possible that the plug-in that's getting loaded when this crash happens might not make it into the "loaded modules list" before the crash takes us down.

Thierry, what plug-ins do you have installed?  If Firefox 3.5.x will start up, you can get the list from the tab in the Add-ons Manager there; otherwise, running

ls ~/Library/Internet\ Plug-Ins/ /Library/Internet\ Plug-Ins/

in the Terminal should provide a useful list.

Comment 3

9 years ago
Here after the feed-back from my plug-ins list :
/Library/Internet Plug-Ins/:
AdobePDFViewer.plugin			PandoWebInst.plugin
CitrixICAClientPlugIn.plugin		Quartz Composer.webplugin
DRM Plugin.bundle			QuickTime Plugin.plugin
Disabled Plug-Ins			RACtrlMoz.plugin
DivXBrowserPlugin.plugin		RealPlayer Plugin
Flash Player.plugin			RealPlayer Plugin.xpt
Flip4Mac WMV Plugin.plugin		Silverlight.plugin
Flip4Mac WMV Plugin.webplugin		SpeedDownload Browser Plugin.plugin
Google Earth Web Plug-in.plugin		flashplayer.xpt
JavaPluginCocoa.bundle			iPhotoPhotocast.plugin
NP-PPC-Dir-Shockwave			npdivx.xpt
NPDjVu.plugin				nsIQTScriptablePlugin.xpt

/Users/thierry/Library/Internet Plug-Ins/:
CoolirisEmbedded.bundle		NPMetaStream3.dll
GoogleOneClickPlugin.plugin	Picasa.plugin

Comment 4

9 years ago
When I remove the whole content of those two plug-in directories, Firefow 3.6 is still crashing at the start of Firefox !

Comment 5

8 years ago
Signature	dlopen
UUID	aa9633aa-1592-461b-bda1-a503c2100405
Time 	2010-04-05 21:19:25.855856
Uptime	1
Last Crash	22 seconds before submission
Product	Firefox
Version	3.6.3
Build ID	20100401064631
Branch	1.9.2
OS	Mac OS X
OS Version	10.5.8 9L30
CPU	x86
CPU Info	GenuineIntel family 6 model 7 stepping 6
Crash Reason	EXC_BAD_ACCESS / KERN_MEMORY_ERROR
Crash Address	0x1c12eedc
User Comments	opened an email and clicked on a link in the email and now firefox won't reopen and crashed. https://callcorp.webex.com/callcorp/ldr.php?AT=pb&SP=MC&rID=11019507&rKey=4d6faca291b9328d
Processor Notes 	
Related Bugs

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 		@0x8fe22110 	
1 		@0x8fe13677 	
2 		@0x8fe16d13 	
3 		@0x8fe18283 	
4 		@0x8fe0d48f 	
5 		@0x8fe1062d 	
6 		@0x8fe051ad 	
7 		@0x8fe0bc32 	
8 	libSystem.B.dylib 	dlopen 	
9 	CoreFoundation 	_CFBundleDlfcnLoadBundle 	
10 	CoreFoundation 	_CFBundleLoadExecutableAndReturnError 	
11 	CoreFoundation 	CFBundleLoadExecutable 	
12 	CoreFoundation 	CFBundleGetFunctionPointerForName 	
13 	libnspr4.dylib 	pr_FindSymbolInLib 	nsprpub/pr/src/linking/prlink.c:1139
14 	libnspr4.dylib 	PR_FindSymbol 	nsprpub/pr/src/linking/prlink.c:1240
15 	XUL 	nsPluginFile::GetPluginInfo 	modules/plugin/base/src/nsPluginsDirDarwin.cpp:456
16 	XUL 	nsPluginHost::ScanPluginsDirectory 	modules/plugin/base/src/nsPluginHost.cpp:4820
17 	XUL 	nsPluginHost::ScanPluginsDirectoryList 	modules/plugin/base/src/nsPluginHost.cpp:4937
18 	XUL 	nsPluginHost::FindPlugins 	modules/plugin/base/src/nsPluginHost.cpp:5025
19 	XUL 	nsPluginHost::LoadPlugins 	modules/plugin/base/src/nsPluginHost.cpp:4960
20 	XUL 	nsPluginHost::FindPluginEnabledForExtension 	modules/plugin/base/src/nsPluginHost.cpp:4032
21 	XUL 	nsPluginHost::IsPluginEnabledForExtension 	modules/plugin/base/src/nsPluginHost.cpp:3799
22 	XUL 	nsExternalHelperAppService::GetTypeFromExtension 	uriloader/exthandler/nsExternalHelperAppService.cpp:2600
23 	XUL 	nsExternalHelperAppService::GetTypeFromFile 	uriloader/exthandler/nsExternalHelperAppService.cpp:2722
24 	XUL 	nsFileChannel::MakeFileInputStream 	netwerk/protocol/file/src/nsFileChannel.cpp:302
25 	XUL 	nsFileChannel::OpenContentStream 	netwerk/protocol/file/src/nsFileChannel.cpp:371
26 	XUL 	nsBaseChannel::Open 	netwerk/base/src/nsBaseChannel.cpp:506
27 	XUL 	nsExpatDriver::OpenInputStreamFromExternalDTD 	nsNetUtil.h:228
28 	XUL 	nsExpatDriver::HandleExternalEntityRef 	parser/htmlparser/src/nsExpatDriver.cpp:734
29 	XUL 	doProlog 	parser/expat/lib/xmlparse.c:4588
30 	XUL 	prologInitProcessor 	parser/expat/lib/xmlparse.c:3809
31 	XUL 	MOZ_XML_Parse 	parser/expat/lib/xmlparse.c:1528
32 	XUL 	nsExpatDriver::ParseBuffer 	parser/htmlparser/src/nsExpatDriver.cpp:1027
33 	XUL 	nsExpatDriver::ConsumeToken 	parser/htmlparser/src/nsExpatDriver.cpp:1125
34 	XUL 	nsParser::Tokenize 	parser/htmlparser/src/nsParser.cpp:3120
35 	XUL 	nsParser::ResumeParse 	parser/htmlparser/src/nsParser.cpp:2336
36 	XUL 	nsParser::OnDataAvailable 	parser/htmlparser/src/nsParser.cpp:2985
37 	XUL 	nsJARChannel::OnDataAvailable 	modules/libjar/nsJARChannel.cpp:911
38 	XUL 	nsInputStreamPump::OnStateTransfer 	netwerk/base/src/nsInputStreamPump.cpp:508
39 	XUL 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:398
40 	XUL 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:112
41 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
42 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:200
43 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:121
44 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:506
45 	CoreFoundation 	CFRunLoopRunSpecific 	
46 	CoreFoundation 	CFRunLoopRunInMode 	
47 	HIToolbox 	RunCurrentEventLoopInMode 	
48 	HIToolbox 	ReceiveNextEventCommon 	
49 	HIToolbox 	BlockUntilNextEventMatchingListInMode 	
50 	AppKit 	_DPSNextEvent 	
51 	AppKit 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
52 	AppKit 	-[NSApplication run] 	
53 	XUL 	nsAppShell::Run 	widget/src/cocoa/nsAppShell.mm:859
54 	XUL 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:183
55 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3506
56 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:158
57 	firefox-bin 	firefox-bin@0x1541 	
58 	firefox-bin 	firefox-bin@0x1468 	
59 		@0x1 	

Filename 	Version 	Debug Identifier 	Debug Filename
ct_loader 		EE2BE6822821E7494A5141216763456C0 	ct_loader
RawCamera 		1C7CEA30FFE2B4DE98CED6518DF1E54B0 	RawCamera
WebEx 		2BB2910E61E1708830B73063BE43BB0C0 	WebEx
Component: Plug-ins → Other
Product: Core → Plugins
QA Contact: plugins → other
Whiteboard: [webex]
Version: 1.9.2 Branch → unspecified
Blocks: 396680
Ludovic, why do you say this blocks bug 396680?

Was your change just a typo?
If it wasn't a typo, please explain why.
No longer blocks: 396680
It should have been bug 566614 blocking bug 396680.
> It should have been bug 566614 blocking bug 396680.

But even that doesn't make sense (see the bug for more info).

As I say at bug 566614, I suspect this is an Apple bug.  But until we can reproduce it reliably (even just one of its variations), we can't know for sure (and won't be able to do anything about it).

Comment 10

8 years ago
Any updates to this issue?  I just started having what seems to be the same problem after using FF3.6.8 for many months of use.   It started when I tried to access a WebEx session from a website.  Cannot get FF to load now at all, even after multiple reinstallation and removal of key files.

Comment 11

8 years ago
Using information from this string I removed the WebEx plugin from /Library/Internet Plug-Ins.   Firefox is now operational.  Seems like that plug in was the culprit here.   Not sure why, or what is conflicting with on OSX.
+1 to Robert's experience. FF 3.6.8 OS X crashed when loading s webex session, after which FF would simply crash on startup, regardless of profile. removing Webex.plugin allows FF to start up again.

after some fiddling around i got the crash id from ~/.../Crash Reports, typed it into crash-stats.m.o and the report already had this bugzilla link. that's what i call ingenious, kudos mozilla guys.
Robert and Leho: You might try removing "pluginreg.dat" from your Firefox profile (~/Library/Application Support/Firefox/Profiles/<randomchars>/pluginreg.dat) and seeing if that helps.  (If it does, hold on to the pluginreg.dat file; someone may want to look at it.)

If removing pluginreg.dat doesn't help, try removing it *and* going back to 3.6.7 and/or 3.6.6 temporarily.  If everything is fine in 3.6.7 and always breaks in 3.6.8 in repeated tests, it's possible that some plug-in changes new to 3.6.8 "broke" something.  If so, that's different from what this bug was originally reported about, but it's an important crash nonetheless.

(I've found the WebEx plug-in flaky historically, so it could still be the plug-in being flaky; I couldn't trigger this crash before when I tried to reproduce, and I couldn't find a demo WebEx conference to try to actually use the plug-in, either.)
(Assignee)

Updated

7 years ago
Crash Signature: [@dlopen ]

Comment 14

2 years ago
Closing old bugs in the Plugins component. We aren't going to track issues in 3rd-party plugins in the Mozilla bug tracker. In addition, support for NPAPI plugins will be removed at the end of this year; for more details see the post at https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/

If there is a serious bug in Firefox, it needs to be filed in the "Core" product, "Plug-Ins" component.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.