Closed Bug 53007 Opened 22 years ago Closed 3 years ago

Need to suppress mouseout/mouseover of anonymous content [XBL Demo 2]

Categories

(Core :: XBL, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: jrgmorrison, Unassigned)

References

()

Details

(Whiteboard: [xbl1.0])

Attachments

(1 file)

I don't think this one got filed, so here it is. (Apologies for just 
putting in the newsgroup text). 
---

     Subject: Re: XBL Test Cases
        Date: Fri, 08 Sep 2000 13:22:38 -0700
        From: David Hyatt <hyatt@netscape.com>
  Newsgroups: netscape.public.mozilla.xpfe, netscape.public.mozilla.layout

David Hyatt wrote:
>
> pUnk wrote:
>
> > The "rollover madness" testcase seems to fail sometimes; a roll-out has no
> > effect.
> >
>
> This is a fascinating subtlety of anonymous content.  mouseover and mouseout
> events need to be killed rather than retargeted.  Otherwise a mouseout of
> anonymous content will mistakenly be interpreted as a mouseout of the 
> explicit parent.
>
> Give me a bug.  "Need to suppress mouseout/mouseover of anonymous content."
>
> dave

By the way, this is why I made the test case in the first place... to 
demonstrate why mouseout/mouseover events need to be killed.
er, those last words are yours, not mine.
->future
Target Milestone: --- → Future
Status: NEW → ASSIGNED
Whiteboard: [xbl1.0]
Summary: Need to suppress mouseout/mouseover of anonymous content. → Need to suppress mouseout/mouseover of anonymous content [XBL Demo 2]
*** Bug 63348 has been marked as a duplicate of this bug. ***
->moz0.9
Target Milestone: Future → mozilla0.9
->future
Target Milestone: mozilla0.9 → Future
*** Bug 114564 has been marked as a duplicate of this bug. ***
*** Bug 136487 has been marked as a duplicate of this bug. ***
*** Bug 149295 has been marked as a duplicate of this bug. ***
*** Bug 168769 has been marked as a duplicate of this bug. ***
*** Bug 192722 has been marked as a duplicate of this bug. ***
bryner, how hard would it be to change the retargeting code to do this?
*** Bug 283413 has been marked as a duplicate of this bug. ***
*** Bug 295105 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 406073
Assignee: hyatt → nobody
Status: ASSIGNED → NEW
QA Contact: jrgmorrison → xbl

This works correctly for Shadow DOM, and I think worked for XBL too, at this point, but XBL is removed now.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.