OOPP gnash compatibility: calls NPN_GetValue(NPNVSupportsXEmbedBool) with NULL aNPP

RESOLVED DUPLICATE of bug 526401

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 526401
8 years ago
8 years ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
The gnash plugin crashes on startup because it calls NPN_GetValue(NULL, NPNVSuppotsXEmbedBool) from within NP_Initialize.

* We should just handle this property locally
* We should null-check the aNPP property and fail less horribly if it's null
(Reporter)

Updated

8 years ago
Blocks: 478976
Summary: gnash compatibility: calls NPN_GetValue(NPNVSupportsXEmbedBool) with NULL aNPP → OOPP gnash compatibility: calls NPN_GetValue(NPNVSupportsXEmbedBool) with NULL aNPP
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526401
You need to log in before you can comment on or make changes to this bug.