Closed Bug 530108 Opened 11 years ago Closed 10 years ago

default tab displays leftover characters hidden behind close button when using personas

Categories

(Firefox :: Tabbed Browser, defect)

3.6 Branch
x86
Windows 7
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 522392

People

(Reporter: ian_channing, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3

The left-most tab title display conflicts with the close button.  It seems to require installing a person first - the default with no personas works. If the title is long and disappears off the tab: 

either it is truncated before the space where the close button should be - or - it is displayed across the entire tab and browsing to a site with a short title that does not use the entire tab, leaves the trailing characters of the long title

Reproducible: Always

Steps to Reproduce:
1. Uninstall all personas (bug doesn't occur)
2. Close all tabs
3. Install a persona (I tried with Japanese Tattoo and Groovy blue)
4. Go to a site with a long title that goes off the end of the tab
5. Open a new tab
6. Close the new tab
7. Go to a site with a short title
Actual Results:  
There will be left over characters at the end of the tab

Expected Results:  
The end of the tab should be cleaned up
Do you see what is reported in bug 529745?
I experience this issue as well with Firefox 3.6, right up to and including Beta 4.
(In reply to comment #1)
> Do you see what is reported in bug 529745?
No I haven't had the same
(In reply to comment #2)
> I experience this issue as well with Firefox 3.6, right up to and including
> Beta 4.

Yes, I've just tested this in Beta 4 as well and still get it.
I've tested this in Beta 5 and I still get the same problem.  I've added two image attachments that display a long title and then the leftover characters.
This is the default tab with a long title, the end characters will still be displayed once you go to a page with a short title.
The leftover characters from the previous long title are still displayed at the end of the tab.
Tony or Juan, can one of you see this problem?
I confirm that I still experience this behaviour using 3.5b5 as well.
i can see the leftover title and the ellipses briefly flicker when switching to a shorter title; but only for a split second.   afterwards, it cleans up the trailing characters when the new page with shorter title reloads.

I tried japanese tattoo on windows 7, 3.6beta5.

Reporter, do you have the personas extension installed as well, or just using the lightweight persona theme?
Tony, I just have the lightweight persona theme.  The personas extension is not installed.  I'm using the groovy blue theme.
The issue still persists for me running RC1 on Windows XP Pro.
Looks like it only happens for the area around the tab close button, which is not shown when only one tab is left open. Once you move your mouse over the tab the left-over characters get removed. Looks like we do not correctly invalidate this area. Dao, do you have an idea?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.6 Branch
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522392
Status: RESOLVED → VERIFIED
Duplicate of this bug: 522230
The bug is still there on version 3.6.2 with the default theme (no persona) under Windows XP.
Correction to my previous comment (16), the bug is gone, but only after restarting firefox with the default theme.
Duplicate of this bug: 566588
You need to log in before you can comment on or make changes to this bug.