United Nations homepage messed up

VERIFIED FIXED in M18

Status

()

Core
HTML: Parser
P1
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: R.K.Aa., Assigned: rickg)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [RTM++] fix in hand (1 liner), URL)

(Reporter)

Description

18 years ago
2000091606 M18 Linux

http://www.un.org/english/ lays out wrong, images missing, comments showing,
columns wrong. The js mouseover menus appear in one long column instead of on
each side of the logo. Since one now has to scroll far down to see all links,
the explanation for them becomes "invisible", because it displays out of reach,
near top of page (where it should display).

Comment 1

18 years ago
--> layout, seeing also on win32.

<!-----------------------------------------------
This is the start of bottom utility Navigation bar
------------------------------------------------->

I assume that is causing the problems, as the text is shown in win32.
OS: Linux → All

Comment 2

18 years ago
possibly because this page declares a HTML 4 Strict DTD and doens't even come
close to validating?

Comment 3

18 years ago
over to Parser.
Assignee: asa → rickg
Component: Browser-General → Parser
QA Contact: doronr → janc
(Assignee)

Comment 4

18 years ago
The strictDTD is disabled. I'll take a quick look to see if this has *anything*
to do with the parsing engine.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

18 years ago
The problem is that comments are being parsed in "strictmode" on this page with 
a strict Doctype. I neglected to disable this. It's a one line change. 
Requestion RTM++.
Keywords: rtm
Whiteboard: [rtm+]
(Assignee)

Comment 6

18 years ago
This is related to turning off the strictDTD. It's absolutely essential that it 
go in for RTM, or we'll break on lots of badly formed pages.
Whiteboard: [rtm+] → [RTM+] fix in hand (1 liner)
(Assignee)

Comment 7

18 years ago
marking ++ for review.
Whiteboard: [RTM+] fix in hand (1 liner) → [RTM++] fix in hand (1 liner)
(Assignee)

Updated

18 years ago
Severity: normal → major
Priority: P3 → P1
(Assignee)

Updated

18 years ago
Target Milestone: --- → M18
(Assignee)

Updated

18 years ago
Whiteboard: [RTM++] fix in hand (1 liner) → [RTM+] fix in hand (1 liner)

Comment 8

18 years ago
PDT thought strict dtd was already disabled.  What's the issue now?  Cc'ing
Vidur and Harish.  Please get this bug reviewed and super reviewed.
Whiteboard: [RTM+] fix in hand (1 liner) → [RTM+ needinfo] fix in hand (1 liner)

Comment 9

18 years ago
This involves strict comment parsing ( doesn't happen in the DTD ) in 
HTMLTokenizer. Yes, this should be disabled too.

Updated

18 years ago
Whiteboard: [RTM+ needinfo] fix in hand (1 liner) → [RTM+ need info] fix in hand (1 liner)
(Assignee)

Comment 10

18 years ago
Here's the patch:

Index: nsHTMLTokens.cpp
===================================================================
RCS file: /cvsroot/mozilla/htmlparser/src/nsHTMLTokens.cpp,v
retrieving revision 3.173
diff -r3.173 nsHTMLTokens.cpp
999a1000,1001
>
> #if 0 //set to 1 if you want strict comments...  bug 53011...
1002a1005,1006
> #endif
>
(Assignee)

Updated

18 years ago
Whiteboard: [RTM+ need info] fix in hand (1 liner) → [RTM+] fix in hand (1 liner)

Comment 11

18 years ago
PDT marking [rtm need info] since it appears that the patch hasn't been
code-reviewed yet.
Whiteboard: [RTM+] fix in hand (1 liner) → [RTM need info] fix in hand (1 liner)
(Assignee)

Comment 12

18 years ago
The code has been reviewed and superreviewed by buster.
Whiteboard: [RTM need info] fix in hand (1 liner) → [RTM+] fix in hand (1 liner)

Comment 13

18 years ago
PDT marking back to need info. Reviewer and super reviewer must be distinct.
Whiteboard: [RTM+] fix in hand (1 liner) → [RTM need info] fix in hand (1 liner)
(Assignee)

Comment 14

18 years ago
Ok -- reviewed by Attinasi.
Whiteboard: [RTM need info] fix in hand (1 liner) → [RTM+] fix in hand (1 liner)

Comment 15

18 years ago
pdt:  ++.
Whiteboard: [RTM+] fix in hand (1 liner) → [RTM++] fix in hand (1 liner)
(Assignee)

Comment 16

18 years ago
Fixed by preventing strict comment handling, period.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

18 years ago
SEA 2000101212 linux
The UN pages now look good again - fix fixed everything reported in this bug :)

Comment 18

18 years ago
verified per reporter comments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.