Closed Bug 530111 Opened 10 years ago Closed 10 years ago

Message not deleted after successful detach

Categories

(Thunderbird :: Message Reader UI, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: gyszilagyi, Unassigned)

Details

(Keywords: testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: 20091112084939

After detaching a message and confirming that it should be deleted from the message it continues to be shown as a "live" attachment although the Save and Detach options are grayed out. Double-clicking the attachment will open it in the assigned application.

Reproducible: Always

Steps to Reproduce:
1. Open a message which has an attachment
2 [review]. Right-click the attachment and select "Detach"
3. Save the attachment
4 [review]. When prompted to confirm if the attachment should be deleted, click "Yes"
Actual Results:  
The attachment remains visible in the mail. Detach and Delete options are grayed out, but double-clicking the attachment will open it (i.e. it is not deleted).

Expected Results:  
The attachment should be deleted.
Blocks: qa-tb3.0rc1
Version: unspecified → 3.0
Could attach here an email example of this behavior using above "Add an attachment" link?
You mean an *.eml file? Sure, although I tried with several messages with the same results. I have attached the "before" and "after" situation. Based on the difference in the file size, the attachment has been removed, but the the message still shows the attachment as "live". The Open option works as long as the detached message is not deleted/moved (but even if it is deleted/moved the Open and Save As options remain available).
Confirmed, but I suspect it is a dupe

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091120 Lightning/1.0pre Shredder/3.0.1pre ID:20091120032839

should be block for bug #505172 and dupe of one of bugs which  bug #505172 depens: Gyorgy could see if you agree with one of depens bug of bug #505172?
This is not a bug, but works exactly as intended. As you say yourself, the attachment is deleted from the msg, the msg was shrinking in size, but you can still open the attachment as if it was still there.
This is because it was explicitly written like that: The attachment is replaced with a *placeholder*, which has a link to where you originally stored the attachment file, and lets you open that file on your harddisk.

I looked at the .eml file "after", and it looks exactly as it's supposed to. multipart/mixed with
X-Mozilla-External-Attachment-URL: file:///...

(Aureliano Buendía, I write this in part for you, so that you can diagnose such bugs in the future.)

INVALID.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Thanks for information Ben. ;-)
Ben: thanks for the clarification. Perhaps what confused me was the confirmation prompt TB displays after the message has been detached:

"The following attachments have been successfully saved and will now be permanently deleted from this message:
[file name]

This action cannot be undone. Do you wish to continue?"

While technically this is correct logically after confirming this action I would expect the attachment to be displayed as deleted... Therefore I would suggest to change the wording of this message.
I would rather suggest that the display of Attachments changes (after deletion).
You need to log in before you can comment on or make changes to this bug.