Add-on Manager is not updated with newly selected persona when selecting multiple personas after a switch from a theme

RESOLVED INVALID

Status

()

P2
major
RESOLVED INVALID
9 years ago
9 months ago

People

(Reporter: aakashd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [l10nFxTestday])

(Reporter)

Description

9 years ago
Build Id:

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3 (.NET CLR 3.5.30729)

Steps to Reproduce:
1. Install a regular theme (i.e. NASA Night Launch).
2. Go to www.getpersonas.com
3. Click on "wear this" for one persona (DO NOT restart). (i.e. colorful)
4. Click on "wear this" for a second persona. (i.e. viva)
5. Restart to wear the personas 

Actual Results:
The last selected persona (viva) is not selected (use theme button is not disable and it doesn't have the "Restart Firefox to use" description) in the Add-ons Manager, but after restart that persona is used.

Expected Results:
The Add-ons manager should select the most recently selected persona.
(Reporter)

Updated

9 years ago
Whiteboard: [l10nFxTestday]
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Annoying, but I suspect not a common case so I don't think it'd be worth blocking 1.9.2 on. Nominate if you think we need to look at this more though.

Comment 2

9 months ago
Thank you filing this bug. With the retirement of getpersonas and legacy themes I doubt this is relevant. I did a few quick tests on AMO and couldn't reproduce, so I'm closing.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.