Closed Bug 530239 Opened 12 years ago Closed 12 years ago

Can't see that there are more recipients, and can't expand: "more" cut off by buttons

Categories

(Thunderbird :: Message Reader UI, defect)

defect
Not set
major

Tracking

(blocking-thunderbird3.0 .1+, thunderbird3.0 .1-fixed)

VERIFIED FIXED
Thunderbird 3.1a1
Tracking Status
blocking-thunderbird3.0 --- .1+
thunderbird3.0 --- .1-fixed

People

(Reporter: BenB, Assigned: BenB)

Details

Attachments

(3 files)

Split-off from bug 520249 and bug 530047.

Reproduction:
1. Make the window (main window or standalone window) exactly as wide as the bugzilla comment body or other plaintext mails which wrap at 80 characters.
(That makes sense, because we don't want to waste screen space, and because 80 chars are a natural line length, and we don't wrap HTML mails, so that would let HTML mails wrap at this point, too.)
2. Open mails with many recipients, esp. when the first recipients are not yet in your address book.

Actual result:
- The "other actions" button cover both the "more" button and a considerable part of the email addresses.
- Thus, there is no hint that there are more recipients at all, and you cannot expand the recipients lists, unless you make the window fullscreen (or *much* bigger).

Expected result:
Working UI

Severity:
Major. Reading messages, including body, subject, from, recipients, is a primary function of a mail reader. If we can't even get *that* right, we better don't dare to release.
Attached patch Fix v1Splinter Review
I noticed that the biggest problem is that 2 addresses show, and that plus the button is just too much.
The addresses also can't wrap (which would be the obvious solution): They are already a <description>, but we force the wrapping off with the singleline="true" hack that implements our show/hide toggle, so that's non-trivial to solve.

So, the cheap solution is to show only one address at first, and show others
after "more". I argue that's more useful and also more discoverable than
attempting to show 2 and risking that the "more" is not visible at all.

I also think that this patch is worth to be included in 3.0.

Here is how it looks like: https://bugzilla.mozilla.org/attachment.cgi?id=413735

Bryan, can you live with that, for 3.0, until we found a better solution for 3.1 or 3.5?

I know this will be a bummer, and all workarounds are suboptimal, but I think that the "can't see that there are more recipients" is by far the worst, though.
Assignee: nobody → ben.bucksch
Attachment #413760 - Flags: ui-review?(clarkbw)
Attachment #413760 - Flags: review?(bwinton)
Attachment #413760 - Flags: ui-review?(clarkbw)
Comment on attachment 413760 [details] [diff] [review]
Fix v1

Yeah, it's a pretty low-risk change, and I think I could live with the new UI, if Bryan thinks it's okay.

Later,
Blake.
Attachment #413760 - Flags: review?(bwinton) → review+
Attachment #413760 - Flags: review?(dmose)
Comment on attachment 413760 [details] [diff] [review]
Fix v1

Asking for tb3.0 approval, under the condition that clarkbw agrees.
Attachment #413760 - Flags: approval-thunderbird3?
Attachment #413761 - Attachment description: Screenshot with Fix v1 (and Fix v2 of bug 530047) → Screenshot with Fix v1 (and Fix v2 of bug 530047): One address per default
Comment on attachment 413761 [details]
Screenshot with Fix v1 (and Fix v2 of bug 530047): One address per default

this does not feel good but I suppose until we have a better fix at the next release we can live with this to make sure people have a working expander.
Attachment #413761 - Flags: ui-review?(clarkbw) → ui-review+
Thanks, Bryan! I know this decision was tough for you. Better solution hopefully later in bug 520249.

Checked into trunk:
http://hg.mozilla.org/comm-central/rev/0e228f0f326a

Leaving it open, because I'd like this to get into 3.0.0.
Whiteboard: Landed on trunk, waiting for 3.0.0 approval
(In reply to comment #7)
> Leaving it open, because I'd like this to get into 3.0.0.

As per standard mozilla practice, bugs that are fixed in the latest code base should be marked fixed. The approval flag is for getting the bug into the latest code base.

The only exception I've had to this is blocker bugs (for 3.0 rc/final, not any other release) as we haven't got round to updating our queries.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1a1
Comment on attachment 413760 [details] [diff] [review]
Fix v1

Didn't make 3.0, moving to consider for 3.0.1.

Does this still need Dan's review?
Attachment #413760 - Flags: approval-thunderbird3?
Attachment #413760 - Flags: approval-thunderbird3.0.1?
Attachment #413760 - Flags: approval-thunderbird3-
Attachment #413760 - Flags: review?(dmose)
Attachment #413760 - Flags: review+
Attachment #413760 - Flags: approval-thunderbird3.0.1?
Attachment #413760 - Flags: approval-thunderbird3.0.1+
Comment on attachment 413760 [details] [diff] [review]
Fix v1

r=dmose, a=dmose for 3.0.1; thanks for the patch!
Whiteboard: Landed on trunk, waiting for 3.0.0 approval → [Landed on trunk, has 3.0.1 approval; needs checkin]
blocking-thunderbird3.0: --- → needed
Checked in on branch: http://hg.mozilla.org/releases/comm-1.9.1/rev/c00ac0b4dd45
blocking-thunderbird3.0: needed → .1+
Keywords: checkin-needed
Whiteboard: [Landed on trunk, has 3.0.1 approval; needs checkin]
Mark, thanks for the checkin to branch.
I verified that the more button was only showing after one address.  V. FIX
Status: RESOLVED → VERIFIED
Bug 456596 suggests to introduce a pref for this.
Bug 520249 is still open to create a proper solution.
You need to log in before you can comment on or make changes to this bug.