Mailing lists are not immediately displayed under their parent address books

NEW
Unassigned

Status

MailNews Core
Address Book
--
minor
9 years ago
8 years ago

People

(Reporter: Andrea Govoni, Unassigned)

Tracking

({regression})

1.9.1 Branch
PowerPC
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

If no mailing lists have been ever created in the profile I'm using, the first time that I open the Address Book and create some mailing lists, they don't appear under the corresponding address books until I close and reopen the Address Book window.

I reproduced this issue with the shipping SeaMonkey 2.0 build and with very recent SeaMonkey 2.1a1pre [1] and Thunderbird 3.1a1pre [2] nightly builds.
I cannot reproduce this issue with SeaMonkey 1.1.18 and Thunderbird 2.0.0.23.

[1] Build identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20091116 SeaMonkey/2.1a1pre
[2] Build identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20091118 Shredder/3.1a1pre

Reproducible: Always

Steps to Reproduce:
1. Create a fresh new profile in SeaMonkey 2.0.
2. Open the Address Book.
3. Dismiss the account creation wizard.
4. Create a mailing list in the "Personal Address Book" address book.
Actual Results:  
The new mailing list appears in the address book view in the upper right area of the windows but it doesn't appear under its parent address book in the left column area of the window.

Expected Results:  
An open expanding arrow should appear on the left of the current address book name and the new list should appear under the address book name.

Comment 1

8 years ago
I can reproduce with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100223 Lanikai/3.1b1pre. I did not attempt to reproduce with trunk, nor did I look for dupes.

I'll trust that you say this worked in prior release and mark this as regression.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Mac OS X → All
Version: unspecified → 1.9.1 Branch
You need to log in before you can comment on or make changes to this bug.