"This forum is flat and doesn't allow replies to other replies" article shouldn't be indexed

VERIFIED FIXED in 1.5

Status

--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: stephend, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only, URL)

(Reporter)

Description

9 years ago
(BTW, seems like pagination is screwed up again?)

STR:

1. Load http://support-stage.mozilla.org/search.php?locale=en-US&q=clear+history&lang=en&where=all (search for "Clear history" from the homepage)
2. Click on the "4" pagination (http://support-stage.mozilla.org/search.php?locale=en-US&q=clear+history&lang=en&where=all&offset=30)
3. Scroll down to the bottom article and click on it

Actual Results:

It loads http://support-stage.mozilla.org/en-US/forum/1/3864?s=clear%20history, which says "Error

This forum is flat and doesn't allow replies to other replies"

Expected Results:

Guessing this at least shouldn't be indexed (don't know what's wrong with it in the 1st place, though)
It should be indexed, but it's pointing to a reply instead of to the thread itself.
This happened to me locally when the indexer wasn't in sync with the database.

When using where=all, search results get formatted based on an offset, whether they come from the forum or the KB. I'm guessing 3864 was actually a wiki article. It is also possible that the offset is calculated wrong. I can't reproduce this locally with my old db though.
I did not see this after applying the patch to bug 530668.
Stephen, can you take a look? If Stephen confirms, feel free to close this bug James.
(Reporter)

Comment 5

9 years ago
Yeah, I no longer see this with the patch from bug 530668.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

9 years ago
Verified FIXED.
Status: RESOLVED → VERIFIED
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.