Update dialog shows xml error for French locale

VERIFIED FIXED

Status

defect
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: pascalc, Assigned: cedric.corazza)

Tracking

({regression})

Bug Flags:
blocking-firefox3.6 +

Firefox Tracking Flags

(status1.9.2 beta5-fixed)

Details

(Whiteboard: [3.6Br4])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
The latest trunk nightly has xml error in updating box, 

1/ go to Aide menu
2/ click on Rechercher des mises à jour

expected result:
pop up box looking for updates

actual result:
pop up box with xml error for this entity:  
<label>&manualUpdateGetMsg.label;</label>

(see screenshot)

build id is:

Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.3a1pre) Gecko/20091119 Minefield/3.7a1pre
(Assignee)

Updated

10 years ago
Assignee: bugzilla.fr → cedric.corazza
Status: NEW → ASSIGNED
(Assignee)

Comment 1

10 years ago
It doesn't seem related to the localization but rather to extensions.

I started Firefox with a brand new profile and couldn't reproduce this error.

On my current profile, I deinstalled some extensions, most of them deprecated, and the error has gone away.

For the record, the extensions were:

User Agent Switcher 0.7.2
Test Pilot 0.3
Mouse Gestures Redox 2.0.3
FireFTP 1.0.5
Adblock 0.5.3.043

I reinstalled these extensions on a new profile (with Nightly Tester Tools 2.0.3) and I couldn't reproducethe error.
(Reporter)

Comment 2

10 years ago
I do not have extensions installed for this profile.
(Reporter)

Comment 3

10 years ago
I tested with today's nightly build and the bug is fixed, so looks lilke it wasn't l10n related
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

10 years ago
reopening, Juanb is seeing the problem on 3.6beta4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3.6?
No longer blocks: 318855
I would suspect bug 407875. Juan, can you please test it? Probably other localizations are affected too.
OS: Linux → All
Hardware: x86 → All
Summary: latest trunk nightly has xml error in updating box → Update dialog shows xml error for French locale

Comment 6

10 years ago
Does it prevent automatic upgrades? If yes, I would say a respin for beta4 would make sense, else we would never get a notification for beta5/rc1.

Comment 7

10 years ago
The current tip is fine for french, so doing a respin is an option.

http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/fr/rev/96f135d042bc is the revision with the fix, and it was a reference to &nbsp; in XUL, that entity is only defined in HTML though, AFAIK.

Comment 8

10 years ago
This checkin was made last Saturday, on Nov 21, while beta4 was built later:

Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4

Why hasn't this fix been included in build1?

Comment 9

10 years ago
Because we're building off of sign-off source stamps, and we didn't get a sign-off update for that fix.
(Assignee)

Comment 10

10 years ago
(In reply to comment #9)
I wasn't sure &nbsp; was the root cause of this bug, so I didn't opt in for this changeset.
Also, this entity was also present in 1.9.1 branch and the error don't appear in firefox 3.5.x. Nonetheless, I removed it from the 1.9.1 too and I will opt in if this is the cause of this bug.

Comment 11

10 years ago
I confirm that Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.2b5pre) Gecko/20091125 Namoroka/3.6b5pre doesn't have this bug.

Updated

10 years ago
Whiteboard: [3.6Br4]
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Flags: blocking-firefox3.6? → blocking-firefox3.6+
Resolution: --- → FIXED
Here's the background:

The strings were pre-landed for 1.9.1 (bug 318855), and never saw their bug coming into action before 1.9.2, in particular, the patch that started using those was landed on 1.9.2 on nov 19th (bug 407875).

We did a respin for B4 fr, and that changeset is gonna be in for ongoing 3.6 milestones, too.

Comment 13

10 years ago
(In reply to comment #12)
> We did a respin for B4 fr

Yes, it's working fine now. Thanks! :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.