change titles of crash reports to format needed in bugzilla

RESOLVED FIXED in 1.2

Status

Socorro
General
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: chris hofmann, Assigned: ozten)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
lars has it now set up so if you file a bug in bugzilla using a title like

 [@ nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) ]

that bug will get correlated to the stack signature in all the crash summary and detailed reports.

the problem is that our default reports now use the format of 

 [@nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) ]

for titles on bugs.  when people cut a paste this format into the title field with out the space following the at sign, then the auto correlation doesn't happen and the bug numbers to show up in the crash-stats reports. then we need to go back and edit the titles or explain to people how the correlation system works and what format is required.

if we change the socorro to include the space after the special "[@ " indicator then things will just work by default and things will go smoother and faster din reporting crash bugs.

this should be a simple formating change to make, unless I'm missing something, and hopefulling can be squeezed into the next socorro release.
(Reporter)

Updated

8 years ago
OS: Mac OS X → All
(Assignee)

Comment 1

8 years ago
I will also add this bug# in the comments.
Assignee: nobody → ozten.bugs
Status: NEW → ASSIGNED
Target Milestone: --- → 1.2
(Assignee)

Comment 2

8 years ago
My bad on grabbing the bug, this looks like a backend only change.
Assignee: ozten.bugs → nobody
Target Milestone: 1.2 → ---
Target Milestone: --- → 1.2
Err... I'm pretty sure that the space after "@" doesn't actually matter. Socorro will match on both. I don't think there's anything to fix here.

Comment 4

8 years ago
we've spent time teaching people to use one format (with a space), we shouldn't go off and confuse people.
timeless: Both work just fine. I don't see any reason to change the code so that they don't work just fine.

What's the bug here?
(Assignee)

Comment 6

8 years ago
Lars says it must have the space. taking.
Assignee: nobody → ozten.bugs
(Assignee)

Comment 7

8 years ago
Fixed r1518. Also limiting size of this area to avoid bleed into Sumo link.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.