HTML 5 Audio Tag generated by javascript doesn't stop playing downloaded sound when the tab is closed.

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: matheusavs2, Unassigned)

Tracking

({regression})

1.9.1 Branch
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?, URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Go to this url, start the sound, then leave the page.
The sound will not stop playing.

Reproducible: Always

Steps to Reproduce:
1. Go to the example url
2. Click on "Play"
3. Wait while the sound loads.
4. Exit the page
Actual Results:  
The sound didn't stop when I closed the tab.

Expected Results:  
The firefox should stop the sound.

Comment 1

9 years ago
Confirmed with:
Mozilla/5.0 (X11; U; Linux i686; eo; rv:1.9.1.6pre) Gecko/20091121 Shiretoko/3.5.6pre

WFM with:
Mozilla/5.0 (X11; U; Linux i686; eo; rv:1.9.2b4pre) Gecko/20091121 Namoroka/3.6b4pre
Mozilla/5.0 (X11; U; Linux i686; eo; rv:1.9.3a1pre) Gecko/20091121 Minefield/3.7a1pre
OS: Windows XP → All
Summary: HTML 5 Audio Tag generated by javascript doesn't stop. → HTML 5 Audio Tag generated by javascript doesn't stop when the tab is closed.
Whiteboard: DUPEME?
Version: unspecified → 3.5 Branch

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 2

9 years ago
Confirmed with
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6pre) Gecko/20091120 SeaMonkey/2.0.1pre

WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091121 SeaMonkey/2.1a1pre
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: 3.5 Branch → 1.9.1 Branch

Updated

9 years ago
Summary: HTML 5 Audio Tag generated by javascript doesn't stop when the tab is closed. → HTML 5 Audio Tag generated by javascript doesn't stop playing downloaded sound when the tab is closed.

Updated

9 years ago
Assignee: nobody → chris.double

Updated

8 years ago
Assignee: chris.double → nobody
Looks like this is WORKSFORME on supported branches.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.